Support » Plugin: Contact Form 7 » There was an error trying to send your message.

  • Resolved chilliwax

    (@chilliwax)


    ***POSTING AGAIN DUE TO LACK OF SUPPORT ON PREVIOUS POST***

    Hi, our contact page has suddenly stopped working – we were initially informed by a customer and have tried for ourselves and there is definitely a problem.

    Whenever you try to submit a message you see the following message “There was an error trying to send your message.”

    We have read the info in the following link but something is definitely not right and it can’t be down to the spam reason advised here: –

    https://contactform7.com/faq/after-submitting-the-form-i-get-an-error-message/

    We are using the newest version of wordpress 4.9.1

    It seems a LOT of people are also experiencing this same problem.

    I disabled all plugins and it still doesnt work so very confused why this has suddenly stopped working after we have used it for years without problem!

    We believe there must be a problem with this plugin and woocommerce!!

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • David

    (@affordablewebsitesdenvercom)

    I tried the form and did get the error message you described. Are you receiving your e-mail at myemailaddress@mydomainname.com or something else like gmail or yahoo or hotmail? My suggestions (without spending more time going through the source code) is to try using domain name based e-mail such as myemailaddress@mydomainname.com first. If that does not resolve the issue, try simply deleting the contact form and creating a new, very basic, very simple one and testing that out. Hope that helps.

    Thanks yes this did help and we have figured out what the problem is – it doesn’t work when we use reCAPTCHA on the form so someone needs to look into this as there must be a coding issue of some kind.

    Thanks again for your help.

    +1 on chilliwax’s message. When reCAPTCHA is used, the form doesn’t submit. When removed, it does submit, but it doesn’t show the green confirmation box. It merely empties the form without any notification.

    Jay Terra

    (@voidofinspiration)

    It also should work with an email address outside the domain. I’m having a lot of clients who are complaining about this! I’ll have to use a different mail plugin if this isn’t corrected soon…

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘There was an error trying to send your message.’ is closed to new replies.