Support » Plugin: Lift: Search for WordPress » There was an error authenticating. Please check your Access Key ID and Secret Ac

  • I can see this error has been reported here before. I have provided the correct access key and secret key yet lift-search fails to accept them. They are 100% verifiable correct keys used in other scenarios like aws-cli.

    How can I troubleshoot this issue? Is there a way to turn on logging?

    Kind reagrds

Viewing 10 replies - 1 through 10 (of 10 total)
  • This is additonal http logging taken when verifying the access + secret key:

    Request URL:
    Request Method:POST
    Status Code:400 Bad Request
    Request Headersview parsed
    POST /wp-admin/admin-ajax.php?action=lift_setting&setting=credentials&nonce=0b16b2aca9 HTTP/1.1
    Connection: keep-alive
    Content-Length: 188
    Accept: application/json, text/javascript, */*; q=0.01
    X-Requested-With: XMLHttpRequest
    User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/34.0.1847.116 Safari/537.36
    X-HTTP-Method-Override: PUT
    Content-Type: application/x-www-form-urlencoded
    DNT: 1
    Accept-Encoding: gzip,deflate,sdch
    Accept-Language: nl-NL,nl;q=0.8,en-US;q=0.6,en;q=0.4,de;q=0.2
    Cookie: wordpress_6cf1e9f14312c6ad0e649ff5369d143a=XXXXXX%7C1398118448%7Cd33ece68fa286d92844a9b8d92c17de3; wordpress_test_cookie=WP+Cookie+check; wordpress_logged_in_6cf1e9f14312c6ad0e649ff5369d143a=XXXXXX%7C1398118448%7C1bde216eb59056464f916078a5025812; wp-settings-time-1=1397945651

    Query String Parametersview sourceview URL encoded

    Form Dataview sourceview URL encoded

    Response Headersview parsed
    HTTP/1.1 400 Bad Request
    Date: Sat, 19 Apr 2014 22:14:37 GMT
    Server: Apache
    Access-Control-Allow-Origin: *
    Access-Control-Allow-Credentials: true
    X-Robots-Tag: noindex
    X-Content-Type-Options: nosniff
    Expires: Wed, 11 Jan 1984 05:00:00 GMT
    Cache-Control: no-cache, must-revalidate, max-age=0, public
    Pragma: no-cache
    X-Frame-Options: SAMEORIGIN
    Vary: Accept-Encoding
    Content-Encoding: gzip
    Node: Hardy
    X-UA-Compatible: IE=Edge,chrome=1
    Content-Length: 192
    Connection: close
    Content-Type: application/json

    I have installed the AWS SDK for PHP and have created the following cloudsearch client:

    require ‘/usr/share/nginx/html/cloudsearch/vendor/autoload.php’;

    use Aws\CloudSearch\CloudSearchClient;

    $client = CloudSearchClient::factory(array(
    ‘region’ => ‘eu-west-1’

    $iterator = $client->getDescribeDomainsIterator();
    foreach ($iterator as $domain) {
    echo $domain[‘DomainName’] . “\n”;


    This works flawlessly and the script produces my search domain. It uses the exact same access key and secret key as I’m trying to use in lift-search.

    I’ve tried the lift-search plugin on a different server with exactly the same issue. I’ve tried it on Apache and nginx. I’ve tried it with an older version of WordPress (3.6) and the most recent version 3.9. All situations give the same error wrt access key and security key.

    Looks like the issue is in the lift-search code?

    Just a hunch, does lift-search support the 2013-01-01 API?

    Have you had any success resolving this? We’re hitting this exact same issue.

    Hi mattstep, no unfortunately not, havent heard a peep from the dev team so far. I have the rather horrible suspicion that the plugin doesnt work with the new 2013-01-01 API but can’t proof it.


    Your hunch was right.

    However, I managed to get past this issue by doing the following:

    Located the lift-search\api folder and opened the cloud-config-api.php

    Locate the class Cloud_Config_Request and I updated the version to 2013-01-01

    This change allowed me to create the domain in cloudsearch.

    I’m sure given the AWS API version changes there is possibly some other underlying logic that may need to change – but at least this gets you passed the first hurdle.


    Hope that helps – happy coding!

    tnx aeothomas, will look into your solution!



    I’m having the same issue is this plugin still supported?

    Plugin Author Kevin Langley Jr.


    Hey guys,

    AEOThomas’s solution might work to create the domain in CloudSearch but there are other changes that need to take place in order to upgrade to using the 2013-01-01 version of the API.

    We have plans to release a new version here shortly that is using the 2013 API.


    I’ve just installed Lift Search – the plugin looks really promising so thanks to the guys at Voce for producing this at no cost to the WP community.

    Is there any news on a version that supports 2013 API? I’m looking forward to trying Live search out with some real data 🙂


Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘There was an error authenticating. Please check your Access Key ID and Secret Ac’ is closed to new replies.