Support » Plugin: Login by Auth0 » There was a problem with your log in. There is a user with the same email

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Contributor Josh C

    (@auth0josh)

    @earmbrust – I’m sorry for the trouble here. Can you tell me:

    – The plugin and WordPress version you’re using
    – Any relevant errors in the plugin’s error log
    – Any relevant errors in the Auth0 dashboard error log
    – Any recent changes you’ve made to the site (updates, plugins, etc)

    Best first troubleshooting step is to compare your Auth0 setup with the document here, most importantly the Client settings:

    https://auth0.com/docs/cms/wordpress/configuration

    Thank you

    Hi Josh, thanks for the quick reply.
    I went ahead and updated everything to the latest versions, hoping that would resolve the problem. The error still persists:

    WordPress version – 4.9.4
    Plugin version – 3.5.2
    Error log messages for failed logins:

    02/28/2018 19:33:47 WP_Auth0_LoginManager::implicit_login 0 Wrong number of segments

    Logs in Auth0 from same timeframe:

    Type Failed cross origin authentication
    Description The generated token is too large. Try with more specific scopes.

    which is followed by two of these:

    Type Failed Silent Auth
    Description Login required

    The only recent changes made were the updates of WordPress (4.9.3->4.9.4) and Auth0 plugin (3.5.1 -> 3.5.2) to attempt to fix the issue.

    Let me know if I can provide any further details that can help.
    Thank you!

    Plugin Contributor Josh C

    (@auth0josh)

    Happy to help, that’s what we’re here for!

    Can you walk through the Client setup section here and make sure this all matches?

    https://auth0.com/docs/cms/wordpress/configuration#client-setup

    Specifically, make sure that the “JsonWebToken Signature Algorithm” Client setting matches what you have under wp-admin > Auth0 > Settings > Basic.

    Also … is there a reason you’re using the implicit flow? That’s typically used for single-page JavaScript apps and will be deprecated for this plugin at some point. Can you try turning that off and see if logins are processed.

    If you have access to your PHP error log, that might have additional clues. It sounds like you’re not getting an ID token back from the Auth0 API (“Wrong number of segments” is usually indicating no segments, or an empty token).

    I’m subscribed here and will reply back as quick as I’m able.

    Hi Josh,
    Weird. Implicit flow is disabled in the plugin, I’m not sure why it’s throwing that.
    I used the wizard to set up the connection, but when checking it seemed that everything lined up with the configuration page you shared.

    I’ll point out that this isn’t happening with all users, just some.

    In looking at the error logs and I see nothing from the times that this occurred.

    After everything I had one of the affected users try to login again and they got the same error.

    I ran into this before and had to delete the user(s) and move all of their posts to a temporary account then have them log in and WordPress would recreate the user. For some reason it only seems to impact some users.

    We’re backing the users in Auth0 with AD, if that makes any difference.

    Hi Josh,
    Do you know if there’s a way to get support for this through the Auth0 site?
    We have a paid account, and are moving towards an Enterprise account.
    I only ask as this is a fairly high exposure site within our organization, so I’m trying to get things resolved ASAP.

    Thank you!

    Plugin Contributor Josh C

    (@auth0josh)

    I’m happy to help you keep troubleshooting, there is also the community site, which is usually better than here as we have more engineer coverage there:

    https://community.auth0.com/

    Also, you can create a ticket:

    https://support.auth0.com/tickets

    The Auth0 dashboard error messages plus the fact that it’s only specific users tells me that maybe the connection you’re using is requesting too many scopes, or those users have too much data to fit in a token. See here from a different library:

    https://github.com/luisrudge/next.js-auth0/issues/14

    Related from the community site:

    https://community.auth0.com/t/the-generated-token-is-too-large/9144

    Maybe compare the profiles in Auth0 for the users that cannot login with one that can, see if that profile is large on the ones that can’t.

    It sounds like that’s an issue with the implicit flow, most commonly, but you don’t have that turned on. What connection(s) are you using

    Let me know if you decide to continue support elsewhere and I’ll close this.

    Hey Josh!
    I ran out of time with the parties involved and had to go ahead and dupe the user and copy over to have them login to recreate the account. Let’s consider this closed for now, and if something comes up again I’ll bring it up on the community site for a bit higher exposure then.

    I really appreciate your help and time.
    Thank you!

    Plugin Contributor Josh C

    (@auth0josh)

    Thanks for the heads up. If the problem surfaces again, reference this thread on Community and ping me there as well so we’re not starting from scratch:

    https://community.auth0.com/u/josh.cunningham/activity

    This might also be a good time to setup a staging/dev server and see if you can recreate the issue before it happens in production again.

    Lastly, as I’m not convinced that this error is stemming from the WordPress plugin, I’d appreciate a reconsideration of the review you posted.

    Thanks @earmbrust!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘There was a problem with your log in. There is a user with the same email’ is closed to new replies.