Support » Plugin: Google Analytics » There was a problem with Google Oauth2 authentication process.

  • This looks like a very nice app.
    I am setting up for the first time and receive the following message
    “There was a problem with Google Oauth2 authentication process.”

    Do you have any more detail like instructions and URL on how to obtain the access code?

    I found a google site and obtained an API key but not sure if Access code = API and if it does if I set it up correctly.

    Please let me know

Viewing 15 replies - 1 through 15 (of 25 total)
  • Hi @aljohn23,

    Thank you so much for the kind regards! I hope we can help solve this issue today 🙂
    When authenticating via Google you should see 2 pop ups that appear once accepting. Here’s a screenshot of what it looks like:
    https://s.w.org/plugins/googleanalytics/screenshot-4.png?r=1576768

    A pop up with an access code key should appear once you login via Google.

    Can you send a screenshot of what you are seeing on your end? Additionally can you confirm that you’re using the latest version of our plugin and WordPress?

    I am getting this error as well. I am using the latest version of WordPress. After I click on “allow” and copy the code shown, and I paste it into the textfield and submit, the error appears:

    
    There was a problem with Google Oauth2 authentication process.
    

    Having the same issue, I know it’s not a google problem because I’ve tested this in my local machine and works fine, same account, but now that I’m implementing this in the server it does not work, it keeps generating this message, I’ve checked the console log and apache2/error.log and nothing is there,

    Any clues on how to solve it?

    Thanks,

    I’ve uploaded my screenshots here: https://www.dropbox.com/sh/xvsdmussquce2hz/AADrZqjJmusJ-9zNOJhTSuSYa?dl=0

    But there’s nothing special on them.

    Hi @clearfickle & @crosstantine,

    Thanks for reaching out and providing great screenshots.
    We’re still not able to replicate this issue you’re having.
    Is there any way for either of you to send us over an admin login so I can have our developer team to debug further?

    If so, please email us at: support@googleanalytics.zendesk.com and if you can just refer to this article that would be great.

    Having the same issue

    • This reply was modified 2 years, 9 months ago by ephraimm.

    TIP: Try to do it in Chrome (I tried in Firefox and it didnt work, but in Chrome it did).

    I’m having the same problem. I’ve tried two different google analytics accounts. I’ve tried Chrome, Firefox, and even IOS Safari. No matter what, I get the following error.

    “There was a problem with Google Oauth2 authentication process.”

    Please help!

    Plugin Author ShareThis

    (@sharethis)

    Hi @joelwroberts thanks for reaching out and letting us know.

    This error usually comes from Google when you access code is wrong. Please make sure to copy the full code after you sign in with Google (without any spaces) https://s.w.org/plugins/googleanalytics/screenshot-4.png?r=1588579

    • This reply was modified 2 years, 9 months ago by ShareThis.

    Not sure if folks are still having this issue, but the second screen shot that @brandonsharethis is referring to may be hidden behind another window. After clicking the Authenticate With Google button, make sure to hover over your browser bar at the bottom of your screen to see if any other windows have opened. Chances are that the second window referenced is open but rather than popping up where you can see it, it’s hidden behind your current window. It should be labeled something like ‘success code’. Hope that helps.

    Hi, I’m having the same problem. I have tried on both Safari and Chrome. I am definitely copying the full code with no spaces. Any ideas?

    Have you set up a Google Analytic account?

    If no, like what happened to me, then setting one up will resolve this problem.

    Yes, the Google Analytics account is set up, signed into, and open in another tab.

    Same for me. My Google analytics account is open and setup in another tab. I’ve tried Chrome and Safari with No luck

    Hi @mhimel, @bamconsulting, @joelwroberts and @ephraimm,

    Thank you so much for reaching out and reporting on this issue!
    A problem with Google Oauth2 authentication process usually shows up when you put wrong code (from Google sign in) or an issue with the Google Account.

    We’d love to live test this with anyone via screen share in Google hangout. If you can write into our support at: support@googleanalytics.zendesk.com

    And let us know what time works best for you, I’m sure we’ll be able to get to the bottom of this!

    Thanks again and looking forward to hear from you guys!

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘There was a problem with Google Oauth2 authentication process.’ is closed to new replies.