Support » Plugin: Keyring Social Importers » There was a problem connecting to Twitter…

  • Resolved rjt1985


    Hi there,

    Thanks for the plugin. It seems on the surface that it’ll do all that I’m hoping it does.

    However, I’m trying to connect to Twitter to pull in my Tweets as posts, but I’m getting this error…

    “There was a problem connecting to Twitter to create an authorized connection. Please try again in a moment.”

    I’ve tried this several times with the same outcome.

    Any idea why it would be doing this?

    Many thanks,


Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Beau Lebens



    Did you create an app on Twitter ( and configure those details in Keyring (Tools > Keyring > Add New > Manage (next to Twitter) )?

    It’s not currently very clear, but each different service (most of them) requires configuration at the Keyring level before you can connect to it. That involves creating an “app” or some sort of registration on that service, and then normally copy-pasting a Key/Secret of some sort.

    If you’ve already done that, then maybe try enabling KEYRING__DEBUG_MODE ( and see if you get anything useful (you’ll get a LOT of output) in your server’s error_logs.

    Hope that helps.

    Hi Beau,

    I haven’t tried to debug yet, but I had already tried to set up my API keys for Twitter, but some reason no matter how many times I input them (on the Add New Connection screen), I click save, go back to Managed Connections and it says “You haven’t added any connections yet”.

    Any idea why this would be?

    I’ve tried various browsers just in case that was an issue, but it still isn’t working.

    Thanks for the swift reply.

    If I did the DEBUG thing, would you mind taking a look at the results because I have literally no idea what I’m looking for.

    Many thanks,


    Plugin Author Beau Lebens



    A couple of things:

    – when you set up Twitter, you’re actually setting up the app-level details to allow Keyring to connect with Twitter. You still need to then actually create a user-level connection
    – Under Tools > Keyring > Twitter > Manage, you should be entering the ‘Consumer key’ and ‘Consumer secret’ in the API Key and Secret fields, respectively
    – Once you’ve done that, you can go back and click through to create a connection to Twitter. It should ask you to log into Twitter (or just confirm if you’re already logged in) then redirect you back to your WP install

    LMK how you go with that.

    Thanks for the reply.

    So I’ve gone to, logged in, created a new app. Then ive created an access token aswell just in case.

    Then I logged into wordpress, went to Tools, Keyring, Twitter and entered the correct codes as you specify above, clicked save, and it says “your credentials are saved”. Then I go back to the manage connections page on Keyring and it still says that I have no connections!

    And of course, because of this, the Twitter importer comes up with the error in the original post.

    I don’t THINK I’m doing anything wrong. Is this a bug, or maybe a problem with the new twitter API rules?

    Plugin Author Beau Lebens



    OK, in the steps you’ve described above, you’ve finished configuring Twitter at the application level, but you still haven’t made a user connection.

    When you go to Import > Twitter, it should say something about needing to connect still, and give you a button to connect:

    when you click on that, you should then go through the connection flow for Twitter (which takes you over to Does that happen?

    Once you come back from, you should see the rest of the importer options:

    If you’re not seeing any of that, then maybe you could post some screenshots of what you are seeing?

    Also, you shouldn’t need to “create an access token” on, you should be using the details under “OAuth settings” (Consumer key/secret).

    Yeah, it still says I need to connect to Twitter, but when I try to connect (on Import –> Twitter) that’s where it’s just going to that error page above (I.e. “there was a problem connecting to Twitter…”)

    So I’ve input all of the API details (as you specified above) into Tools –> Keyring –> Twitter, clicked Save, it says it has saved but if you go back to Tools –> Keyring it still says I haven’t made any connections (even though I just have).

    I then go to Import –> Twitter, click connect to Twiiter and it comes up with a white screen with the “There was a problem connecting to twitter…” message. It never actually takes me through to Twitter to make a connection.

    Sorry for the lack of screenshots. I’m on my phone. However, I’ve described it exactly how it is above.

    ps. Yeah I know I didn’t need to create an access token, I just did this time in case that was the problem. I still entered the correct details into Keyring.

    Any ideas Beau?

    Having the same problem when I add Instagram credentials in Keyring. Keyring says that it’s saved the details, but when I view the connections I’ve made it just shows this screen:

    I’m guessing this is some kind of bug with Keyring?

    Plugin Author Beau Lebens



    I’ve just released updates to both Keyring and the Importers, so you should probably update. They’re nothing specifically to do with your problems, but they might help, who knows.

    Anyway — the screen you’re showing me is “expected”. After configuring a service (Twitter/Instagram), you still haven’t actually connected to it, you’ve just set up your server (WP) to be able to talk securely to that service.

    At that point, you need to click the link to Add a New Connection, then click the name of the service (Twitter/Instagram) in the top list of services (you’ll see what I mean about top list vs bottom list once you update Keyring + Importer plugins).

    Then you should be redirected to either Twitter or Instagram to grant access. If you’re not, please post a screenshot of whatever error you get, or whatever happens.

    Hi Beau. The update has fixed my issue! 🙂 Although it potentially could have been to do with me not setting a callback URL (?).

    Anyway, it’s working now. I have some additional questions if you’ve got some spare minutes to have a read through. I’ve posted them in a new thread on the support forum.

    Plugin Author Beau Lebens



    OK, yeah I think it was actually because you didn’t set a call back URL. You have to configure one of those for Twitter apps to work properly for some reason.

    Glad it’s working now.

    Cheers mate. Let me know your thoughts on my other queries when you get a second.

    Scratch that, I’ve just seen your reply.

    Thanks again.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘There was a problem connecting to Twitter…’ is closed to new replies.