Support » Plugin: Facebook Chat Plugin - Live Chat Plugin for WordPress » there is any way to hide the popup

  • there is any way to hide the annoying popup banner in messenger and show only when user click?

Viewing 15 replies - 1 through 15 (of 15 total)
  • follow

    Plugin Author Facebook

    (@facebook)

    Hi,

    You can follow our developer documentation to make advance changes. The wordpress plugin doesn’t provide a direct way to modify that. If you are comfortable with directly editing the wordpress html/css files, you can set the greeting_dialog_display to hide.

    https://developers.facebook.com/docs/messenger-platform/discovery/customer-chat-plugin/

    Regards
    Facebook Team

    Thread Starter Yorgos

    (@dblii)

    thanks but your plugins have a lot of bugs and conflicts, try to fix it

    Thread Starter Yorgos

    (@dblii)

    It should be more helpfull to give an example how to applie this atributes. Thanks

    Change facebook-messenger-customer-chat.php in line 38

    <div class='fb-customerchat'
            attribution='wordpress'
            page_id=".get_option( 'fbmcc_pageID' )."
            >
    </div>

    after:

    <div class='fb-customerchat'
            attribution='wordpress'
    	greeting_dialog_display='hide'
            page_id=".get_option( 'fbmcc_pageID' )."
            >
    </div>

    Din’t mind, go for this free plugin which does the job just fine :

    Live Chat (Messenger API) + PolyLang

    Thread Starter Yorgos

    (@dblii)

    Thanks a lot. I dissable the plugin because it is garbadge. I added manual code

    <!-- Load Facebook SDK for JavaScript -->
          <div id="fb-root"></div>
          <script>
            window.fbAsyncInit = function() {
              FB.init({
                xfbml            : true,
                version          : 'v6.0'
              });
            };
    
            (function(d, s, id) {
            var js, fjs = d.getElementsByTagName(s)[0];
            if (d.getElementById(id)) return;
            js = d.createElement(s); js.id = id;
            js.src = 'https://connect.facebook.net/el_GR/sdk/xfbml.customerchat.js';
            fjs.parentNode.insertBefore(js, fjs);
          }(document, 'script', 'facebook-jssdk'));</script>
    
          <!-- Your customer chat code -->
          <div class="fb-customerchat"
            attribution=setup_tool
            page_id="xxxxxxxxxxxxxxx"
      theme_color="#0084ff">
         </div>
    <div class="customer-chat"
     page_id="xxxxxxxxxxxxxxx"
    greeting_dialog_display="hide">
    </div>

    but not working, what is wrong?

    Thanks

    Din’t mind, go for this free plugin which does the job just fine :

    Live Chat (Messenger API) + PolyLang

    Thread Starter Yorgos

    (@dblii)

    Works just better than the original with custom options and the exact same overlay.

    Thread Starter Yorgos

    (@dblii)

    nice to here that, @bastienchilloux i just wondering if is so difficult for facebook to build a plugin to comunicate and work correctly with there platform

    I think they are not wondering about those plugins as it doesn’t make them money back in any way I guess.

    I tried @webalive change in code but it doesn’t work. The chat (popup with text) opens every time page is loaded or reloaded – on mobile, desktop is ok, but but it was month ago too.

    @pokornytomas – I believe it’s a browser issue on mobile. It’s hidden on Firefox and Safari in my test – but on chrome on my android it will not work.

    This is an issue for @facebook to solve 🙂

    • This reply was modified 1 year, 4 months ago by webalive.

    That plugin Live Chat (Messenger API) + PolyLang still didn’t work for me – on incognito mode still popup appears and even in wrong language (english), how can I try to fix it?

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘there is any way to hide the popup’ is closed to new replies.