Support » Fixing WordPress » There has been an error cropping your image.

  • Resolved tempogenic

    (@tempogenic)


    Hello, WordPress nation! I surely believe you can help.

    From the Dashboard, I select Customize Your Site -> Header Image -> Add new image. After uploading my image, I select “Select and Crop”, adjust the crop selection, then select “Crop Image”. Then I get the message “There has been an error cropping your image.”

    This is a fresh install of WordPress 4.7 on Amazon Linux AMI, only the default plugins installed, no plugins active. I am using Chrome Version 55.0.2883.95 (64-bit) on OX X El Capitan and have also tried Firefox. I have tried both 2011 and 2016 themes, confirmed that php5-gd is installed, cleared browser cache, and restarted my browser. I installed httpd24, php56, mysql55-server, and php56-mysqlnd prior to installing WordPress.

    WordPress is installed in /var/www/html, and permissions are set as follows:

    chown -R apache:www /var/www
    chmod 2775 /var/www
    find /var/www -type d -exec chmod 2775 {} \;
    find /var/www -type f -exec chmod 0664 {} \;

Viewing 9 replies - 1 through 9 (of 9 total)
  • Moderator t-p

    (@t-p)

    Have you tried:
    – Flushing any caching plugins you might be running, as well as server and/or browser caches. Not just your browser, but any op cache or content network cache as well such as Cloudflare. If your host provider has a “Purge Varnish” option or if you can ask your provider to flush memcache on your server.
    – deactivating ALL (yes all) plugins temporarily to see if this resolves the problem (plugin functions can interfere). If this works, re-activate them individually (one-by-one) to find the problematic plugin(s).
    resetting the plugins folder by FTP/ SFTP (no Dashboard access required). Sometimes, an apparently inactive plugin can still cause problems. Also remember to deactivate any plugins in the mu-plugins folder (if you have created such folder). The easiest way is to rename that folder to mu-plugins-old.
    – switching to the unedited default Theme (Twenty Sixteen, etc.) for a moment using the WP dashboard to rule out any theme-specific issue (theme functions can interfere like plugins).

    I described most of this in my post. I just tried resetting the plugins folder per the link you posted, and that had no effect, either.

    Moderator t-p

    (@t-p)

    Thank you for the link. I enabled debugging. Unfortunately, no additional messages were generated.

    $ grep DEBUG wp-config.php
    * It is strongly recommended that plugin and theme developers use WP_DEBUG
    define(‘WP_DEBUG’, true);
    define(‘WP_DEBUG_LOG’, true);
    define(‘WP_DEBUG_DISPLAY’, true);

    I completed a fresh install of WordPress on a new server and also tried cropping an existing image that comes with the WP installation. Cropping still fails.

    Any other ideas?

    On a whim, I tried “sudo yum install -y php56-gd” and now it works. The issue was with the version.

    Moderator t-p

    (@t-p)

    Glad to know it 🙂

    Hello,

    please can anybody explain this issue to somebody who is not a programmer/developer?? From this I have no idea what to do and I still get the error while trying to upload the image with Customiser.

    where should I install this php5-gd thing?

    I am having this issue only on one account, I manage another WordPress website and this isnt happening there..

    thank you

    • This reply was modified 2 years, 11 months ago by Petra47.
    Moderator t-p

    (@t-p)

    @petra47,

    If you noticed OP has marked this thread “resolved” about 2 m0nths ago!!

    If the troubleshooting already posted made no difference for you, then, as per the Forum Welcome, please post your own topic. That way you stand a good chance of getting the assistance you want.

    I’m closing this thread.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘There has been an error cropping your image.’ is closed to new replies.