WordPress.org

Forums

Theme[thebox] still showing excerpts (3 posts)

  1. Coffeetology
    Member
    Posted 1 year ago #

    Hey guys, I've been struggling with this for several hours, reading up on possible fixes, and etc, trying to figure out how to change The Box theme's tiny default excerpts into fully displayed posts.

    I have tried replacing the_excerpt() with the_content() and this has not worked.

    I have tried changing the $excerpt = implode(" ",$excerpt)."... <br><a class=\"more-link\" href='" .get_permalink($post->ID) ." '>".__('Read more', 'thebox')." &raquo;</a>"; (in the functions.php) to various other forms of the_content() and it only breaks the site.

    The loop in my single.php file reads `<?php if (have_posts()) : ?>
    <?php while (have_posts()) : the_post(); ?>
    <?php the_content(); ?>
    <?php endwhile; ?>
    <?php endif; ?>`

    I can't imagine what else needs to be done. It's very irritating because the 'read more' is only 3 words long. Any help would be appreciated!
    Thanks.

  2. MyNanoTank
    Member
    Posted 1 year ago #

    I'm also struggling to work out how to do this...

  3. MyNanoTank
    Member
    Posted 1 year ago #

    @Coffeetology - I got this to work, by creating a child theme.

    Firstly, try installing the "One-Click Child Theme" plugin and create your child theme.

    Then edit the content.php file as outlined by the developer at https://wordpress.org/support/topic/how-to-have-full-posts-instead-of-truncated?replies=4

    Basically, you have to copy the original Box theme's content.php file over to the subdirectory containing the child theme, and then edit it there. "Refresh" and hopefully that should work...

Topic Closed

This topic has been closed to new replies.

About this Topic