Support » Alpha/Beta/RC » Themes – Sufficient Permissions

  • I installed 3.0 RC1 last night. This morning I decided to install the theme I used throughout 2.9.2, Mandigo. It looks like install goes okay by looking at my site, but when I go to Theme Options in the Admin Panel, an option visible once Mandigo is installed, it tells me:

    “You do not have sufficient permissions to access this page.”
    at /wp-admin/themes.php?page=ThemeOptions

    Is this a bug with 3.0, with Mandingo, a mix, and what can I do to fix it so I can view the Theme Options page?

Viewing 15 replies - 1 through 15 (of 15 total)
  • I don’t know much about the Mandigo theme; But did you check the chmod of the theme files?

    Becuase usually theme options appearing in the Dashboard writes values to existing files.


    I have the same issue. Did you find a fix?

    I did get the same error as well .. i tried changing the permissions with the theme option file but with no luck at all… did u guys find a fix?

    well i did find a fix. well basically its not a fix lets just say i found what was causing it..

    there is a issue in the url
    when you upgrade to WP 3.0

    the url of the theme options page changes from Options

    the problem is that when upgraded to WP 3.0 the space between the “theme Option” is removed thus givin a error

    try navigating to the theme page and add a space to the theme option area then it will work..

    i still didnt figure out where i have to make the changed in the code to make this work when you click the theme options button..

    i hope u guys can post how to do that if u guys succeed in changing it

    Just add a “_” to the space between “Theme options” and “HTML inserts” inside those php files

    will work like a a charm

    Oh very thank you knightofdoom that work for my blog

    Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    Yeah, the call to the theme’s options page will need to be fixed by the theme author.

    I had the same problem, and in addition, the sidebars don’t display correctly. In the theme options page the sidebars were set to appear to the left and right of the main column, but they both appear to the right. I had Mandigo installed before the upgrade to 3.0, and it was working correctly under 2.9.2.

    I asked about this on the theme’s home page, and it has now been upgraded to be WordPress 3.0 compatible; the current version is 1.42. I’m about to upgrade it and see if this fixes both these problems.

    I had same problems as labcoatman. Upgrade Mandigo to 1.42 no solution for me. I had to de-activate NextGen Gallery Plugin to have sidebar problem solved. I believe some CSS from NextGen Gallery screws up Mandigo’s sidebar handling, but I am definitely a newby on CSS so dare not look for solution myself.

    For labcoatman. Do you use NextGen Gallery ? in that case, nextgen setting thumbnail javascript effect is probably causing the problem.
    See for solution.



    I just upgraded to Mandigo 1.42 and regained access to the HTML Inserts and Theme Options panels. No need to change your themes.php.

    realy big thanks! i have same troble with Royale 1.5.1
    so, link must be

    Yep, it worked for me … I just added the “_” where the space is between the two words in “Theme options” and “HTML inserts” in the two php files… the first two instances of these phrases in each file. I did not want to upgrade Mandigo because I’ve modified it a fair amount…

    Update… after I fixed the “Them options” and “HTML Inserts” links, it turned out I could not click on the “Update Options” button if I changed anything from within the Theme options. It gave the same message, “You do not have sufficient permissions to access this page.”

    So, I went to the Mandigo website and got the latest versions of

    functions.php, and

    I changed extensions on the existing files to “php_old” and
    then ftp’d the three files to their appropriate locations
    (two are in the backend folder of Mandigo).

    It worked, and all seems find now.

    It’s easy to go to the Mandigo website and compare old versions to the latest and see what’s changed, so that an update need not involve replacing all the files…

    envt – thanks so much for the timely post.
    just upgraded WP and had the same problem with Mandigo.
    This saved me lots of work and frustration.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Themes – Sufficient Permissions’ is closed to new replies.