WordPress.org

Forums

[resolved] Themes not working on multi site application (19 posts)

  1. jhavelka747
    Member
    Posted 1 year ago #

    Does not matter what theme I use, one of wordpress's themes or our custom theme. Theme works on main page, but the sub pages it does not show up. Please let me know what I can do.

    [Signature removed by moderator per forum rules.]

  2. Jonathan Dingman
    Member
    Posted 1 year ago #

    Can you provide some links so we can see an example of what you're describing? You didn't provide that much information to go off of.

  3. jhavelka747
    Member
    Posted 1 year ago #

    the main site works, faceoffviolation.com but when you go to the sub page, faceoffviolation.com/acupabruin (Example, we have 30 of them and none of them work. Same set up on all of them.)

    I have tried wordpress themes and our custom themes, it does not matter. Same problem.

    Let me know

    Thanks for your help.

    [Signature removed by moderator per forum rules.]

  4. Jonathan Dingman
    Member
    Posted 1 year ago #

    When you go to the sub-site, then view the source, you can see that the css file is throwing a server error, which means it's not configured correctly.

    http://faceoffviolation.com/acupabruin/wp-content/themes/resportsive/style.css

    That should render the css file, but it's not.

    likely something to do with .htaccess not being setup properly.

    Try making .htaccess writable and re-running your permalinks settings.

  5. jhavelka747
    Member
    Posted 1 year ago #

    Sorry, how do I make .htaccess writable? I will try to figure out the permalink thing later, but I am hosted on Godaddy so will that make a difference? I have been down this road before, so if you could give me as much detail as possible please that would be great.

    [Signature removed by moderator per forum rules.]

  6. http://support.godaddy.com/help/article/2504/what-is-htaccess

    Start there :) You'll need an SFTP or SSH client to log in and edit it.

  7. jhavelka747
    Member
    Posted 1 year ago #

    So, we did what you told us, and now I am getting another error. I must be the only human in the world that just can not get Multi site to work. Error 404

    faceoffviolation.com is working. Faceoffviolation.com/acupabruin is now getting a 404 error. Any help here. This has been about a month now. Does this actually work or is there a better option?

    Thanks

    [Signature removed by moderator per forum rules.]

  8. Jonathan Dingman
    Member
    Posted 1 year ago #

    You're definitely not alone, Jason. I always recommend to my clients to move away from GoDaddy, I would explore that as an option.

    It still sounds like a mod_rewrite problem, it should be working.

    I would check your error_log files and see if there's anything going on.

  9. Hi @jhavelka747,

    I notice that your permalinks are set to the default on the main site. Can you change that to something other than the default?

    You mention that /acupabruin is a subpage. To be clear, is it a page on the main site or is it the name of a sub-site? That is, if you go to

    http://faceoffviolation.com/wp-admin/network/sites.php

    do you see acupabruin in this list?

  10. jhavelka747
    Member
    Posted 1 year ago #

    Yes you see it on the list. Also, I reset permalinks. That also does not seem to help.

  11. Are you 100% sure you named the file .htaccess ? This is VERY important.

    Also I got this odd error...

    The requested URL /faceoff/htaccess was not found on this server.

    Is WP installed in a subfolder?

  12. jhavelka747
    Member
    Posted 1 year ago #

    Okay, you may have something. What file should be named .htaccess? The file exists on the root at Godaddy. Once I dial into Godaddy, and to the file manager, then to Faceoff, .htacess is there. Should it be somewhere else or am I missing something. Sorry if I am frustrating you, just not a strong tech background.

    Thanks

    Jason

  13. It should be in the same folder as your wp-config.php file.

  14. jhavelka747
    Member
    Posted 1 year ago #

    it is, and it does say .htaccess. Though we took everything out of it all it has is a start and finish to it. This is what we took out.

    RewriteEngine On

    RewriteBase /

    RewriteRule ^index\.php$ - [L]

    # add a trailing slash to /wp-admin

    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]

    RewriteCond %{REQUEST_FILENAME} -d

    RewriteRule ^ - [L]

    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) faceoff/$2 [L]

    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ faceoff/$2 [L]

    RewriteRule . index.php [L]

  15. Well... That's all the htaccess code FOR multisite. So it won't work without that, certainly.

  16. jhavelka747
    Member
    Posted 1 year ago #

    I just added it all back in and faceoffviolation.com/acupabruin shows up, but we are now back to square one again. No theme. error codes when you access internal logins.

  17. Jason,

    It's the faceoff that is messing things up. I'm not an expert on htaccess or GoDaddy, but in your htaccess you have

    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ faceoff/$2 [L]

    This basically says take all of that stuff before .php and the end of the string and then prepend it with faceoff. Now, I'm guess that faceoff is the name of the cPanel user because you said

    to the file manager, then to Faceoff,

  18. faceoff should be a folder name actually. It's not abnormal for a server to have that.

    What version of WP were you running when you started with Multisite? If it was BEFORE 3.5, we'll need to jigger about, but this is the default for Multisite 3.5+ in subfolders:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
  19. jhavelka747
    Member
    Posted 1 year ago #

    Thank you, it was that last fix... Great Job Guys!!!!!!!!!!!

    Jason

Topic Closed

This topic has been closed to new replies.

About this Topic