WordPress.org

Support

Support » Installation » [Resolved] Themes not visible after upgrade to 2.0.5

[Resolved] Themes not visible after upgrade to 2.0.5

  • My blog was hacked yesterday** (more about this below), so I did an upgrade from 2.0.4 to 2.0.5 after changing passwords, checking directory/file permissions, etc.

    Now, I can change themes via wp-admin (just changed back to the default theme) – but while my content is visible, none of the themes how up on the site itself. I’ve tried disabling/re-enabling plugins, double-checking to make sure I have all the necessary files, comparing files to the most recent backup, etc. Does anyone have any ideas here?

    http://www.mywhimislaw.com

    Thanks in advance for any and all help,
    Betsy

    ** Whoever got in put in a referrer that sent my site to a page on an abandoned .us site after a 5 second or so lag – yet my hosting company (GoDaddy) couldn’t find anything on the site itself/in the logs, so insisted it was a WP problem. Updating from 2.0.4 to 2.0.5 fixed the referrer problem & I briefly had a blog with a theme, but it reverted back to the view you see now after reloading the page and/or opening a different browser.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You might want to do a search for 2.0.5 problems. Seems like this thing’s come up before…. I don’t think it’s the same problem that Mark’s plugin fixes though.

    And I think personally that a new host is in order.

    That’s why there is no style on your blog:
    http://www.mywhimislaw.com/wp-content/themes/classic/style.css

    That’s bizarre. I have permissions set to allow for access on this file. This one was at 776, for example.

    I just did a spot check; all of the other CSS pages associated with various themes have similar permissions.

    Is there a larger global setting here?

    Gosh…. all my blogs have folders set 755, files set 644. I don’t have anything set higher permitted than that. Must be something else, Betsy.

    I had stuff like that happen when my previous host did some serious restricting using mod_security rulesets. Did you find anything in searching on 2.0.5 problems?

    I didn’t find anything relevant when I searched for 2.0.5 problems, no.

    At this point, I’m looking at a delete and total reinstall from scratch scenario – can’t see any other way around it, unfortunately…

    Be sure you have a couple redundant database dumps/backups. Then if you do a clean install and are still having the problem that points strongly to two possibles: something server-side (which hopefully your host can help you sort out though considering your host that may be a forlorn hope), or something wonky in the database – and that may be much harder to sort.

    A clean install solved the problem, hooray!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Themes not visible after upgrade to 2.0.5’ is closed to new replies.
Skip to toolbar