Support » Networking WordPress » Themes not showing in admin

  • Resolved snotra


    After upgrading to WP 3.4.1, my themes is not showing in /wp-admin/network/themes.php.

    The themes was working and showing fine before the upgrade. Message: no themes found.

    All the subdomains is still using the theme it have been activated with, but no one of the themes are showing in the network admin.

    In the subdomain admin previously activated theme is visible and working, but not any of the other network activated themes are visible.

    If I upload a new theme it is installing successfully, but it is not apparing in network admin.
    This is an subdomain before 3.4.1 upgrade:

    My new subdomain got the twentyeleven theme, but because the network admin will not show my themes, I am not able to change this:

    I have tried to upload the same themes in a ordinary WP installation, and the themes is working just fine. I have also checked if the themes is in wp-content/themes.

    I have tried to deactivate all plugins, but nothing changes.

    Please give me any advice on what to do!

Viewing 10 replies - 1 through 10 (of 10 total)
  • John


    It may be a problem with your .htaccess file. This problem seems similar to yours.

    Go look in /wp-content/themes and make sure they’re all there 🙂

    Have have checked /wp-content/themes – all the files is ok. I have also tried to install themes via FTP and via admin (zip). I have checked the themes at a one site installation of WordPress, and they are working fine.

    I have checked my .htaccess file, and it seem ok. I have a backup of the .htaccess from before the upgrade, but nothing is changed.

    If I upload a new theme it is installing successfully, but it is not apparing in network admin.

    Do the old themes show up there?

    No, just the active theme is showing in the admin for the subdomain. All the sites have different active themes, but none of the active themes is showing up in network-admin. I’ve checked that I am super admin.

    Two questions, one to be pedantic, one to try to debug.

    When you say they don’t appear in network admin, you mean wp-admin/network/themes.php right?

    And to debug, you should try turning off all your plugins on the main site.

    Yes, just one theme showing in /wp-admin/network/themes.php. But this theme is not the same I use on the subdomains. I have made a sceenshoot to explain better:

    I have already tried to deactivate all plugins, nothing changed.

    Hi Snotra,

    Just wondered if you were able to sort this issue at all? I’m having exactly the same problem in WordPress as you described and there’s definetly an issue with 3.4.1 as never had this happen before.


    Yes, I did find a solution: If you go to network-admin and to the list of sites (/wp-admin/network/sites), you can change the template with network-settings for the site you need to change. Scroll down to “template” and “stylesheet” and change the theme/css name.

    Thank you for your quick response and glad to hear you got it sorted. Will give that a try…

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Themes not showing in admin’ is closed to new replies.