Support » Fixing WordPress » Themes do not show

  • Hello, I got started with wordpress just yesterday and got most of it running as I want it. But somehow my page does not show any themes, it’s just blank text.

    http://www.technophile.eu

    On the wp-admin screen, the two standard themes show up for selection, but they too don’t show any graphics. The description is there, but the pictures are blank. I added a new custom theme, but it is exatly the same with it.

    I think it started when I tried to change the URL in wp-admin, but that caused me to be unable to log in anymore. I fixed that with adding the lines
    define(‘WP_HOME’,’http://news.technophile.eu’);
    define(‘WP_SITEURL’,’http://news.technophile.eu’);

    to the wp-config.php file and restore the original paths. And I think it was the same time, that the themes started to be no longer displayed.

    Can anyone help me with this?

Viewing 6 replies - 1 through 6 (of 6 total)
  • On the wp-admin screen, the two standard themes show up for selection, but they too don’t show any graphics. The description is there, but the pictures are blank. I added a new custom theme, but it is exatly the same with it.

    I guess you meant screenshot thumbs by graphics.. Where did you put the screenshot.png of these themes? in themes/theme-name/screenshot.png ? And are they CHMOD 644? Can you still activate the themes?

    I didn’t change anything. It’s all as I uploaded it for the first installation of wordpress.
    The only changes I made was adding the “define” lines to the wp-config.php.
    And yes, I can change themes. But as they both don’t show up, it doesn’t make a visible difference.

    whooami

    (@whooami)

    Member

    look at your source —

    but they too don’t show any graphics. The description is there, but the pictures are blank. I added a new custom theme, but it is exatly the same with it.

    where do the images point to, what are the urls?

    Yes, if it is a front end image issue then the links to the images might be off like WhoamI said… You can check for faulty urls in the post or in PHPMyAdmin

    Nile Flores

    (@blondishnet)

    Yoast Support

    Really, you only need to define your home in your WP admin panel in the general settings.

    Is this a manual installation or an auto-install. I do not want to guess either way, but you should not have to change your core files too much other than follow what your installation directions say for WordPress.

    I would double check JUST IN CASE to make sure your screenshot.png files are actually in each of your themes. If so, try even re-uploading a copy of those if the are showing.)

    As I had just started, I deleted the database and reinstalled again, so, as you might see, the page is working now.

    But as the problem might reoccour later, I’d lake to understand how it happened.

    I downloaded the latest version of wordpress, created a database, and dumped all the files from the download on the webspace. Then I entered the db informations to the wp-config.php, uploaded it to the server, and then opend /wp-admin/install.php.
    I hadn’t done anything else and it seemed to work fine, but the problems apparently started when I tried to change the WordPress adress in settings on /wp-admin. I restored it with the “define” lines to the wp-config.php, but then the layouts did’t have any effect any longer.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Themes do not show’ is closed to new replies.