Themes (css) is not visble from other computers (3 posts)

  1. Music_Mogul
    Posted 5 years ago #

    Hello Everyone,

    I have WAMP server and wordpress installed on my home computer. WordPress is located in the following directory "H:\wamp\www\BlogWebsite\wordpress".In order for people on my network or out my network to view my wordpress page I did the following:
    In the Apache configuration file (httpd.conf), I changed
    # Virtual hosts
    # Include conf/extra/httpd-vhosts.conf to
    # Virtual hosts
    Include conf/extra/httpd-vhosts.conf
    In the Apache virtual host configuration (httpd-vhosts.conf), I added the following
    <VirtualHost *:80>
    ServerName localhost
    DocumentRoot H:/wamp/www
    <VirtualHost *:80>
    ServerName Blog
    DocumentRoot H:/wamp/www/BlogWebsite/wordpress
    In the hosts.conf (C:/Windows/System32/drivers/etc), I added the following localhost Blog
    I went in the general settings in wordpress and changed the wordpress and site addresses to http://Blog/BlogWebsite/wordpress
    Click save and restarted wamp services but now my themes are not visible on my local computer and on computers in my network. Everything is just plain text and when I click on link on my plain text blog, I get an error saying that the page can not be found. I checked in the error log in Apache and I got the following error directory H:/wamp/www/BlogWebsite/wordpress/Blogwebsite does not exists. I do not understand why the pages are being referred to H:/wamp/www/BlogWebsite/wordpress/Blogwebsite. Also I tried changing my wordpress and site addresses to http://myrealip/BlogWebsite/wordpress but that does not work either.

    Can someone tell me what I am doing wrong?

  2. 123milliseconds
    Posted 5 years ago #


    do like this

    no no http://myrealip/BlogWebsite/wordpress

    yes http://myrealip/

    ---- Blog

    already points to INSIDE

    DocumentRoot H:/wamp/www/BlogWebsite/wordpress

  3. delsey
    Posted 5 years ago #

    I just had this problem. In your blog general settings make sure that WordPress Address and Site address are of the form:




    localhost will be resolved to the LOCAL machine which will only work on the machine running the webserver.

Topic Closed

This topic has been closed to new replies.

About this Topic