WordPress.org

Forums

zeeBusiness
[resolved] Header not resolving to home (18 posts)

  1. Rastl
    Member
    Posted 2 years ago #

    Clicking on the header doesn't return to the home page.

    I would prefer not to add a site title if possible since it clutters up my header. The site title will link back to the home page.

    http://wordpress.org/extend/themes/zeebusiness/

  2. Mohd Rafie
    Member
    Posted 2 years ago #

    You will either need to do a child theme, or you can modify the header.php

    And change the custom-header DIV to this:

    <div id="custom_header">
    	<a href="<?php echo home_url(); ?>/">
    		<img src="<?php echo get_header_image(); ?>" />
    	</a>
    </div>

    This is providing the fact you're installing your website on your server and not hosting it at wordpress.com

  3. Rastl
    Member
    Posted 2 years ago #

    That's working by replacing the lines but now the rest of the page is off alignment.

    Putting it back didn't put the alignment of the site back to normal.

    http://www.rastlworldminis.com

  4. Mohd Rafie
    Member
    Posted 2 years ago #

    That is weird because what I add is the

    <a>
    tags to the image and that didn't disturb the DIV layout

    It seems like you might delete or add additional DIV while trying to remove the header title that cause the wrapper not to wrap things properly.

    Try this for your header.php:

    <!DOCTYPE html><!-- HTML 5 -->
    <html <?php language_attributes(); ?>>
    
    <head>
    	<meta http-equiv="Content-Type" content="<?php bloginfo('html_type'); ?>; charset=<?php bloginfo('charset'); ?>" />
    	<link rel="pingback" href="<?php bloginfo('pingback_url'); ?>" />
    
    	<title><?php bloginfo('name'); if(is_home() || is_front_page()) { echo ' - '; bloginfo('description'); } else { wp_title(); } ?></title>
    
    <?php if ( is_singular() ) wp_enqueue_script( 'comment-reply' ); ?>
    <?php wp_head(); ?>
    </head>
    
    <body <?php body_class(); ?>>
    <div id="wrapper">
    
    	<div id="header">
    
    	<?php if( get_header_image() != '' ) : ?>
    		<div id="custom_header">
    			<a href="<?php echo home_url(); ?>/">
    				<img src="<?php echo get_header_image(); ?>" />
    			</a>
    		</div>
    	<?php endif; ?>
    
    	<div id="navi">
    		<?php
    		// Get Navigation out of Theme Options
    			wp_nav_menu(array('theme_location' => 'main_navi', 'container' => false, 'menu_id' => 'nav', 'echo' => true, 'fallback_cb' => 'themezee_default_menu', 'before' => '', 'after' => '', 'link_before' => '', 'link_after' => '', 'depth' => 0));
    		?>
    	</div>
    	<div class="clear"></div>
    
    	<div id="wrap">
  5. Rastl
    Member
    Posted 2 years ago #

    Almost but not quite. The header isn't lining up with the rest of the page so there's an odd overlap on the right side. The logo image and the top menu bar aren't aligned with the body of the page.

    Any idea why this would be an issue on my site but not yours?

    I appreciate the help!

  6. Andrew
    Forum moderator
    Posted 2 years ago #

    This is because you have an image width of 900 pixels, but your containing element (<div id="header">) has padding of 10px left and right of the element (line 76 style.css); therefore increasing the total width to 920 pixels.

    I would recommend (while using a child theme for the CSS) adding overflow hidden on your header element.
    E.g

    #header{
     overflow: hidden;
    }
  7. Rastl
    Member
    Posted 2 years ago #

    The header itself seems to be having issues now because none of the pages resolve. It goes back to the catalog page.

    Would a fresh installation be the way to go at this point?

  8. Andrew
    Forum moderator
    Posted 2 years ago #

    none of the pages resolve

    I can't see what you mean, the navigation menu? If so, it appears to me that the pages link correctly.

  9. Rastl
    Member
    Posted 2 years ago #

    You're seeing something completely different from me then. I've tried different browsers and had the same issue.

    I started a thread in the general troubleshooting forum. The URL in the address bar is correct, it just keeps trying to go to the first subpage in the list.

    Reinstalling the theme and adding back the snip of code for the logo to take me back to the home page worked and the rest of the page looks fine. This isn't a theme issue any more, I think.

  10. Andrew
    Forum moderator
    Posted 2 years ago #

    Actually I see your problem on this now.
    Are you using a plugin for the navigation menu?

  11. Andrew
    Forum moderator
    Posted 2 years ago #

    Does this ring a bell:

    Please specify a ShareThis Publisher Key
    For help, contact support@sharethis.com

    ?

    Also when I click on louis xix link, it shows this error message

    GET http://www.rastlworldminis.com/workbench/louis-xix-and-louis-xix-v/ 404 (Not Found) /workbench/louis-xix-and-louis-xix-v/:458

  12. Rastl
    Member
    Posted 2 years ago #

    The only plugin I'm using that has anything to do with the menu is WP e-commerce and it put in the first navigation pages. They stay in the menu when I disable the plugin but don't resolve. All the other pages go to a blank page as well when the plugin is disabled.

    Why would all the pages want to resolve to that first page in the menu?

    Update - I tried rearranging the menu items so Products Page was second and the pages still resolved to the Products page. So page order doesn't seem to be the issue.

    The "ShareThisPublisher Key" message doesn't ring a bell. Where are you seeing that?

  13. Andrew
    Forum moderator
    Posted 2 years ago #

    Possibly the pages cannot be found and in the .htaccess file, a redirect is set to use the Products page?

    Or maybe the other pages have accidently been assigned the wrong template?

    The "ShareThisPublisher Key" message doesn't ring a bell. Where are you seeing that?

    It's in my error log of the browser, Chrome v.21

  14. Rastl
    Member
    Posted 2 years ago #

    Re-updating the theme color and the background color got the pages to resolve correctly. The "ShareThisPublisher" is still showing up as an error but not a fatal one at this point. I have no idea where that's coming from in the code, to be honest.

  15. sputnik suzi
    Member
    Posted 2 years ago #

    Hello, I have the same problem as Rastl, and followed the advice above, replacing the text in the header.php so that it includes a link to the homepage in the 'custom header'. Unfortunately this doesn't seem to have had any effect, which is rather strange. The header doesn't link to anything at all.

    I'm fairly new to WordPress and also to php, but I have some (rusty!) html.

    Can anyone help? Thanks very much!

  16. esmi
    Forum Moderator
    Posted 2 years ago #

    @sputnik suzi: As per the Forum Welcome, please post your own topic. Posting in an existing topic prevents us from being able to track issues by topic. Added to which, your problem - despite any similarity in symptoms - is likely to be completely different.

  17. sputnik suzi
    Member
    Posted 2 years ago #

    My site is http://www.indianbooksuk.com by the way

  18. sputnik suzi
    Member
    Posted 2 years ago #

    Sorry, just seen esmi's post, will post my problem as a new topic. Thanks!

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic