Support » Theme: WP-Creativix » [Theme: WP-Creativix] Support Needed – Widgets and Parse Error

  • I am needing some support on this theme. I just installed it, and have two issues.

    The first is that I get this error message at the bottom of my blog on any page other than the home page:
    Warning: Division by zero in /home/coastalp/public_html/momentslesstraveled.com/wp-content/themes/wp-creativix/page.php on line 26

    I have not messed with any coding at all, simply just the functions as they are available through this theme. Any help would be much appreciated, otherwise, I’m off to find another theme that does work.

    The second is that my widgets are not displaying.

    Any help would be greatly appreciated.

    http://wordpress.org/extend/themes/wp-creativix/

Viewing 15 replies - 1 through 15 (of 22 total)
  • Theme Author IWEBIX

    (@iwebix)

    Hi,

    Thank you for bug-reporting. Didn’t find the bug on my Dev-Site but I think the problem is that <div class="wp-pagenavi"><?php wp_link_pages('before=Pages: &pagelink=<span>'%'</span>'); ?></div> needs to be in the loop.

    Cut this line (26) in page.php and insert it before:

    <?php endwhile; endif;?>

    That should do the trick, will be fixed upon next Update!

    Cheers

    Hi I did this and now I have the same message but with line 21 cant you just do an update please

    Yes I can confirm the same issue after following the suggestion:

    Warning: Division by zero in /home/director/public_html/wp-content/themes/wp-creativix/page.php on line 21

    I hope iwebix updates this soon as I think it has all the basics of a good theme. I hope they do it soon.

    Theme Author IWEBIX

    (@iwebix)

    The Update is already in Progress, just waiting for a sync of the WP-Team 😉

    Personally, I hate situations like this, where different bugs look the same. At least I think its different since it’s in a different file.

    I think I’ve learned that the first thing I start with should NOT be a static page. May-be it will useful to know that I got ‘Division by zero’ error when I had nothing but the WordPress boilerplate content, but after I tried to set the no-sidebar control. That’s when I got this:

    Warning: Division by zero in
    /mypath/wp-content/themes/wp-creativix/tpl_page_nosidebar.php on line 32

    I got the appearance I wanted with slider and featured blog posts after I went to Settings – Reading and set Front Page displays Posts.

    This Theme needs a few more instructions for users like me who can screw up a good thing by over thinking stuff.

    I’ve just encountered the same error, though on a live build which is exactly the same as my local build (I get no errors on the local server).

    I removed the line:

    <div class="wp-pagenavi">
         <?php wp_link_pages('before=Pages: &pagelink=<span>'%'</span>'); ?>
    </div>

    and replaced it with:

    <div class="wp-pagenavi">
    	<?php
    		get_template_part('scripts/wp-pagenavi');
    	        if(function_exists('wp_pagenavi')) { wp_pagenavi(); }
    	?>
    </div>

    Same code as found in tpl_portfolio.php

    Not really sure why they’re different, but the error’s gone and the nav menu still works.

    Hey Trav3lingMan,

    Well done. Many thanks, worked for me too.

    Cheers.

    Hi to all,
    I am having many problems in setting up wp-creativix theme. its search is directed to xampp folder and menu is not adding. Can any one have a tutorial or a video on setting up this theme?
    I will be very grateful. Thanks.

    Curious if I can get any help on this…

    I notice that when I go to an archive page, it does not paginate. It only shows the number of posts that I have specified in the admin to show one page at a time, so there is no way to get to my older posts. Any idea how to fix this so pagination is available?

    I also want to customize the home page. I’d rather have the blogroll in the space that lists most recent posts (since I have those in the slider at the top), and an about page content/text content on the left, and recent comments (the actual comments, not just a person posting) in the middle. On the blog posts page, I’d like to have a tweet button not just the fb and google share buttons. Anyone know how to make these things possible?

    This is a really clean theme that has a lot of potential if a few details were ironed out.

    Also, the right and left arrow buttons that appear just under the sliders do not work. If you put your mouse over them, it appears to want to let you click, but it doesn’t do anything.

    the problem seems to be the % – When you remove this it works, but is the final fix?

    This is doing modular division with the %

    <div class=”wp-pagenavi”>
    <?php wp_link_pages(‘before=Pages: &pagelink=<span>’%'</span>’); ?>
    </div>

    NOTE:If I run this code

    <?
    echo ‘before=Pages: &pagelink=<span>’%'</span>’;
    exit;
    ?>

    PHP Warning: Division by zero in xxx.php on line 2

    Hi everyone,
    I’m having exactly the same problem as coastalpetrescue

    I notice that when I go to an archive page, it does not paginate. It only shows the number of posts that I have specified in the admin to show one page at a time, so there is no way to get to my older posts. Any idea how to fix this so pagination is available?

    I tried to do what digital_me suggests without success.

    I would like to know if anyone solved this pagination problem?

    Here is the link to my blog… http://rocol.com.co/blog/?cat=10
    There are more than 10 posts in this category, however there are no pagination links to go to the rest.

    Please HELP!
    Thanks

    @rocol: I see that you have solved pagination problem on your site, can you tell me how? Thx before

    In wp-content/themes/wp-creativix/tpl_page_nosidebar.php

    Remove the single quotes around %
    I put the OLD and NEW line of code below
    PHP is treating this as a mathematical operation in the OLD scenario

    OLD:<div class="wp-pagenavi"><?php wp_link_pages('before=Pages: &pagelink=<span>'%'</span>'); ?></div>
    NEW:<div class="wp-pagenavi"><?php wp_link_pages('before=Pages: &pagelink=<span>%</span>'); ?></div>
Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Theme: WP-Creativix] Support Needed – Widgets and Parse Error’ is closed to new replies.