Support » Installation » Theme won’t apply

Theme won’t apply

  • Hi,

    It seems I just can’t apply the theme on the blog page. I get is all the information on a straight column to the left of the page… ??

Viewing 15 replies - 1 through 15 (of 21 total)
  • My theme is also not working. Earlier I was having problem where my permalink pages weren’t loading but my homepage http://kmareka.com was. So I went into options and looked at the two boxes, one for the domain name which I had at http://kmareka.com and one for the Blog URL which I had at http://kmareka.com/index.php. I changed the Blog URL to http://kmareka.com and updated, and then ther permalink pages were working and everything seemed fine. But then I went to try old permalinks from other sites and found they were searching for the address with the /index.php in the tag so then I went back to the site and put the /index.php back in on the options, updated, and suddenly I got an error message and now I get an error message when I try to go to my dashboard, so I can’t go in and change things back. Help! Thanks, Kiersten Marek

    The values in the two URI fileds can NOT end to file names. Only folder names (without trailing slash)!

    You may want to try to add the index.php to the permalink settings, but don’t mess with it in the Options.

    To fix it: http://www.tamba2.org.uk/wordpress/site-url/

    I have wp 1.5. When I go into my database I do not see a file for “home”. Could it have another name?

    Sorry, I did find the “home” file and changed it to http://kmareka.com. However, I am still getting an error message when I try to go to my dashboard and my theme is not applying to my site. Kiersten

    Here’s how this it is presented to me: http://www.elsiane.com/blog . It tells me theme applied and them this??

    The real problem is that I can’t get into my dashboard. What would be preventing me from being able to do that?

    kiersten, you have to change BOTH values: site_url and home to http://kmareka.com
    (note: http://www.example.com and example.com are not the same!)

    Seemingly you did not change the values, it is still looking for the stylesheet in the wrong place:
    @import url( http://kmareka.com/index.php/wp-content/themes/nolimits/style.css );

    I did find the “home” file

    Just for the record: there are no “files” in the database. You change the data or entry or values… just follow exactly the tutorial.

    They are both changed to http://kmareka.com

    But the theme is not applying.

    My friend, believe me, it is NOT changed. Look at the source code and you will see it is looking for the stylesheet in the wrong place: at the URI with index.php at the end.

    I know this is fixable because all I did was change the value in the blog URL on the options page. If I can just go to the place in that page and change it — I assume that is what changing “site URL” and “home” does. But won’t this make all the links I have from other sites get error pages? If so, I guess that’s the price to pay to have the site back up. But why was the site working before with one box of options saying http://kmareka.com and the Blog URL box saying http://kmareka.com/index.php. What changed to make the permalink pages suddenly stop working (error message) when the homepage was still working? That was the original problem and the reason why I went in and looked at my options page and then made the change, which seemed to work initially with getting the permalink pages to come up. Thanks so much for your help.

    First things first.
    1. Priority #1 – make the site work properly.
    2. Think about old outside links later: you can ask for a htaccess redirect for those, and I am sure somebody will help.
    3. Is the stylesheet link by any chance hardcoded in the theme’s header.php file?
    4. I am also wondering how did it work with a faulty URI in the options…

    This is the contents of my header php file. I don’t believe there is anything in it hard-coded:

    @header(‘Content-type: ‘ . get_option(‘html_type’) . ‘; charset=’ . get_option(‘blog_charset’));
    if (!isset($_GET[“page”])) require_once(‘admin.php’); ?>
    <?php get_admin_page_title(); ?>
    <!DOCTYPE html PUBLIC “-//W3C//DTD XHTML 1.0 Transitional//EN” “http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd”>
    <html xmlns=”http://www.w3.org/1999/xhtml”>
    <title><?php bloginfo(‘name’) ?> › <?php echo $title; ?> — WordPress</title>
    <link rel=”stylesheet” href=”<?php echo get_settings(‘siteurl’) ?>/wp-admin/wp-admin.css?version=<?php bloginfo(‘version’); ?>” type=”text/css” />
    <meta http-equiv=”Content-Type” content=”<?php bloginfo(‘html_type’); ?>; charset=<?php echo get_settings(‘blog_charset’); ?>” />

    <script type=”text/javascript”>

    function customToggleLink() {
    // TODO: Only show link if there’s a hidden row
    document.write(‘<small>(<?php _e(‘Show hidden’); ?>)</small>’);
    // TODO: Rotate link to say “show” or “hide”
    // TODO: Use DOM

    function toggleHidden() {
    var allElements = document.getElementsByTagName(‘tr’);
    for (i = 0; i < allElements.length; i++) {
    if ( allElements[i].className.indexOf(‘hidden’) != -1 ) {
    allElements[i].className = allElements[i].className.replace(‘hidden’, ”);

    <?php if ( isset($xfn) ) : ?>

    function GetElementsWithClassName(elementName, className) {
    var allElements = document.getElementsByTagName(elementName);
    var elemColl = new Array();
    for (i = 0; i < allElements.length; i++) {
    if (allElements[i].className == className) {
    elemColl[elemColl.length] = allElements[i];
    return elemColl;

    function meChecked() {
    var undefined;
    var eMe = document.getElementById(‘me’);
    if (eMe == undefined) return false;
    else return eMe.checked;

    function upit() {
    var isMe = meChecked(); //document.getElementById(‘me’).checked;
    var inputColl = GetElementsWithClassName(‘input’, ‘valinp’);
    var results = document.getElementById(‘rel’);
    var linkText, linkUrl, inputs = ”;
    for (i = 0; i < inputColl.length; i++) {
    inputColl[i].disabled = isMe;
    inputColl[i].parentNode.className = isMe ? ‘disabled’ : ”;
    if (!isMe && inputColl[i].checked && inputColl[i].value != ”) {
    inputs += inputColl[i].value + ‘ ‘;
    inputs = inputs.substr(0,inputs.length – 1);
    if (isMe) inputs=’me’;
    results.value = inputs;

    function blurry() {
    if (!document.getElementById) return;

    var aInputs = document.getElementsByTagName(‘input’);

    for (var i = 0; i < aInputs.length; i++) {
    aInputs[i].onclick = aInputs[i].onkeyup = upit;

    window.onload = blurry;
    <?php endif; ?>


    <?php do_action(‘admin_head’, ”); ?>

    <div id=”wphead”>
    <h1><?php echo wptexturize(get_settings((‘blogname’))); ?> <span>(“><?php _e(‘View site’) ?> »)</span></h1>

    require(ABSPATH . ‘/wp-admin/menu-header.php’);

    if ( $parent_file == ‘options-general.php’ ) {
    require(ABSPATH . ‘/wp-admin/options-head.php’);

    To clarify, this came about because earlier today my homepage was opening with the wordpress theme, but permalink and category pages were giving me an error message. I went into the options for wordpress and there were 2 boxes, one for domain and one for site URL. In these slots originally, the first had http://kmareka.com and the second had http://kmareka.com/index.php. I thought perhaps this was what was causing the error messages, so changed the second box to just http://kmareka.com. Then I viewed the site and the category pages and permalink pages were working so I thought everything was fixed. Then I realized outside links would be looking for the code with the /index.php in the code, so I went back and tried to change the second option to http://kmareka.com/index.php to see if the pages would work. When I hit “update” I got an error message and ever since then I have not been able to get into wordpress. They recommended I go into myphp database and change “site url” and “home” values to http://kmareka.com but the theme is still not applying.

    I’m not sure why I can’t go to the dashboard for my site — I get an error message. But the content of the site is loading the wordpress features such as permalink and category pages are working, but the theme page is not. I noticed that I have an “option name” called called “recently edited” that has this content:


    I notice that this part has a feature for “autoload” which is on “no.” whereas almost everything else is on “yes” for autoload.

    Could these things be key to the problem?

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘Theme won’t apply’ is closed to new replies.