Support » Fixing WordPress » Theme-wide style break

  • I’m working on a site for a friend and suddenly the site is broken after the header. I switched themes, I upgraded to 2.0.4, and I tried deactivating all the plugins, I can’t figure out what’s making this happen.

    I thought it was the stylesheet (the content background disappears, sidebar drops below content) but it’s happening in every theme, and attempting to use the exact same theme on my test site works fine.

    View the issue here: http://redredwhine.com

    Any suggestions? I just gave the site a fresh upgrade from 2.0.1 to 2.0.4, I’ve tried using different themes, no plugins are activated, I’m not sure where else to look to troubleshoot. Any suggestions are welcomed.

    Thanks in advance.

Viewing 9 replies - 1 through 9 (of 9 total)
  • no plugins are activated…
    Hmm. Take a second look at the sidebar.

    Dude, that plugin is sooo deactivated. I’ll uninstall and try again.

    Ok, I had the plugin deactivated but the php to call it up was still there.

    And the problem persists even with themes that weren’t using that plugin. Now the code is gone and the plugins are gone, and the problem is still there.

    🙁

    This is the post to fix: http://www.redredwhine.com/?p=375

    Ok, how’d you figure that out?

    Magic. 😉

    I clicked on each post on your main page to see the “single” view of it.

    That was the post that showed a broken single view. Odds are, there’s some extra/malformed HTML wedged into it.

    Might just edit it and select all contents and copy to clipboard.
    Start up a text editor (notepad if on windows) and Paste.
    Then copy from text editor back to the WP editor.
    See if that clears it?

    Well privatizing that post didn’t work, but some post was screwy because changing the display to show only four posts did the trick.

    Still not sure what the problem was, or what about that or any other post was screwing it up, though.

    AH.
    Ok, I can see she’s adding weird HTML to certain entries. Woooo. Thank you so much, I didn’t even think of that.

    Heh. Welcome to “but it worked and validated when I handed it off to you!”

    Try to get her to understand that if she won’t use the plain editor in wp (or even goddess forbid the wysiwyg), she then needs to use notepad instead of word or whatever other oddball thing she’s writing in.

    If that doesn’t work, you have two other options (besides murder….): tell her you won’t fix it if she won’t behave; or download and install Open Office for her (http://openoffice.org) – which last time I looked, works pretty much like word but doesn’t throw quite as much crap into the mix.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Theme-wide style break’ is closed to new replies.