WordPress.org

Forums

[closed] Theme: twenty twelve, make responsive - unresponsive (9 posts)

  1. barbarachicgeek
    Member
    Posted 2 years ago #

    Hi there,

    I have a website, http://www.highpointrealestategroup.com that is currently using the twenty twelve theme, and the theme is responsive. Is there an easy way to "turn off" the responsive theme and make the site unresponsive?

    Thank so much to anyone who could help,

    Chic-Geek

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    Do not edit the Twenty Twelve theme. It is the default WordPress theme and having access to an unedited version of the theme is vital when dealing with a range of site issues. First create a child theme for your changes.

  3. Andrew
    Forum moderator
    Posted 2 years ago #

    No, there is not an easy way to turn off responsiveness in Twenty Twelve because it's built into the theme from the ground-up.

  4. rossi muzza
    Member
    Posted 2 years ago #

    In the child themes’ header.php, I removed the section:
    <meta name=”viewport” content=”width=device-width” />

    My twentyeleven header.php was this -

    <head>
    <meta charset="<?php bloginfo( 'charset' ); ?>" />
    <meta name="viewport" content="width=device-width" />
    <title>

    I changed it in my twentyeleven child theme’s header.php to this -

    <head>
    <meta charset="<?php bloginfo( 'charset' ); ?>" />
    <title>

    then In the child theme’s style.css I removed the max-width propery of the #page element and replaced it with width.

    twentyeleven’s style.css -
    #page { max-width: 1000px; }

    twentyeleven child theme’s style.css
    #page { width: 1000px; }

    This worked for me, although we're not using the same theme hopefully it will work for too!

    [Please post code or markup snippets between backticks or use the code button. Your posted code may now have been permanently damaged by the forum's parser.]

  5. toolbelt
    Member
    Posted 2 years ago #

    Rossi Muzza - you are fabulous. That worked for me - haven't tested on all devices yet but it worked for my iphone. Thank you. : )

  6. Rachel Goldstein
    Member
    Posted 2 years ago #

    Oh, this is exactly what I needed. THANKS. I didn't need to change max-width, just needed to remove the viewport line from header.php.

    I have another question though. The site background image contains the logo, and is not showing up on mobile.
    http://www.kbany.com

    Any ideas?

  7. WPyogi
    Forum Moderator
    Posted 2 years ago #

    @RachelGoldstein71 - for other questions unrelated to this topic, please start a new thread per - http://codex.wordpress.org/Forum_Welcome#Where_To_Post

  8. Rachel Goldstein
    Member
    Posted 2 years ago #

    OK, but it is related to the topic. I disabled the responsiveness, as outlined in this thread, which made the other issue apparent.

  9. WPyogi
    Forum Moderator
    Posted 2 years ago #

    Did you see this part of the above link?

    Unless you are using the same version of WordPress on the same physical server hosted by the same hosts with the same plugins, theme & configurations as the original poster, do not post in someone else's thread. Start your own topic.

Topic Closed

This topic has been closed to new replies.

About this Topic