WordPress.org

Forums

[resolved] [Theme: Twenty Thirteen] Header not displaying properly (2 posts)

  1. nrgised27
    Member
    Posted 1 year ago #

    Here is the site in question: http://leesmattressstores.com
    I didn't develop the site, the owner asked me to do some modifications. What was left to be done is to add some "connect with us" icons (it only had fb and rss).
    What I did was edit the header.php adding new lines, similar to fb icon line, but, as you can see it only shows 2 icons on a row and I need to show all 5 on the same row.

    Here is header.php

    <?php
    /**
     * The Header template for our theme
     *
     * Displays all of the <head> section and everything up till <div id="main">
     *
     * @package WordPress
     * @subpackage Twenty_Thirteen
     * @since Twenty Thirteen 1.0
     */
    ?><!DOCTYPE html>
    <!--[if IE 7]>
    <html class="ie ie7" <?php language_attributes(); ?>>
    <![endif]-->
    <!--[if IE 8]>
    <html class="ie ie8" <?php language_attributes(); ?>>
    <![endif]-->
    <!--[if !(IE 7) | !(IE 8)  ]><!-->
    <html <?php language_attributes(); ?>>
        <!--<![endif]-->
        <head>
            <meta charset="<?php bloginfo('charset'); ?>">
            <meta name="viewport" content="width=device-width">
            <title><?php wp_title('|', true, 'right'); ?></title>
            <link rel="profile" href="http://gmpg.org/xfn/11">
            <link rel="stylesheet" type="text/css" href="<?php echo get_template_directory_uri(); ?>/style2.css">
            <link rel="pingback" href="<?php bloginfo('pingback_url'); ?>">
            <!--[if lt IE 9]>
            <script src="<?php echo get_template_directory_uri(); ?>/js/html5.js"></script>
            <![endif]-->
            <?php wp_head(); ?>
        </head>
    
        <body <?php body_class(); ?>>
            <div id="page" class="hfeed site">
                <div id="masthead header" class="site-header" role="banner">
                    <div id="header_info">
                        <!--<a class="home-link" href="<?php echo esc_url(home_url('/')); ?>" title="<?php echo esc_attr(get_bloginfo('name', 'display')); ?>" rel="home">-->
                        <img class="logo" src="<?php echo get_template_directory_uri(); ?>/images/logo.png" onclick="window.location = 'http://leesmattressstores.com/'"/>
                        <!--</a>-->
                        <div class="header_contact_info">
                            <h2 class="site-description">The largest selection of mattresses in<br/>Huntington Beach</h2>
                            <div class="fonesearch-wrapper">
                                <div id="general_contact_info">
                                    <img src="http://leesmattressstores.com/wp-content/themes/twentythirteen/images/telephone-top.png" alt="telephone 0120-665-702" class="telephone">
                                    <a href="https://www.facebook.com/leesmattressstores"s><img class="info-icon" src="http://leesmattressstores.com/wp-content/themes/twentythirteen/images/icon-FB.png" alt="telephone 0120-665-702"></a>
                                    <a href="http://www.pinterest.com/leesmattress"s><img class="info-icon" src="http://leesmattressstores.com/wp-content/themes/twentythirteen/images/icon-pinterest.png" alt="telephone 0120-665-702"></a>
                                    <a href="https://plus.google.com/b/101657766582303753723/101657766582303753723/"s><img class="info-icon" src="http://leesmattressstores.com/wp-content/themes/twentythirteen/images/icon-google.png" alt="telephone 0120-665-702"></a>
                                    <a href="http://www.yelp.com/biz/lees-mattress-stores-huntington-beach-2"s><img class="info-icon" src="http://leesmattressstores.com/wp-content/themes/twentythirteen/images/icon-yelp.png" alt="telephone 0120-665-702"></a>
                                    <a  href="<?php bloginfo('rss2_url'); ?>"><img class="info-icon"src="http://leesmattressstores.com/wp-content/themes/twentythirteen/images/icon-rss.png" alt="telephone 0120-665-702"></a>
                                </div>
                                <?php get_search_form(); ?>
                            </div>
                        </div>
    
                    </div>
    
                    <div id="navbar" class="navbar">
                        <div id="site-navigation" class="navigation main-navigation" role="navigation">
                            <h3 class="menu-toggle"><?php _e('Menu', 'twentythirteen'); ?></h3>
                            <a class="screen-reader-text skip-link" href="#content" title="<?php esc_attr_e('Skip to content', 'twentythirteen'); ?>"><?php _e('Skip to content', 'twentythirteen'); ?></a>
                            <?php wp_nav_menu(array('theme_location' => 'primary', 'menu_class' => 'nav-menu')); ?>
    
                        </div><!-- #site-navigation -->
                    </div><!-- #navbar -->
                </div><!-- #masthead -->
    			 <?php if(!is_front_page()){
    					echo "<div id='bread_crumb'>";
    					bcn_display();
    					echo "</div>";
    					 }
    			?>
                <div id="main" class="site-main">
  2. nrgised27
    Member
    Posted 1 year ago #

    It was a CSS issue, I do not know exactly how to solve it so I could post the solution here, a friend did it for me.

Topic Closed

This topic has been closed to new replies.

About this Topic