WordPress.org

Support

Support » Themes and Templates » Twenty Eleven » [Theme: Twenty Eleven] How do I get "Recent Posts" to stop appearing ?

[Theme: Twenty Eleven] How do I get "Recent Posts" to stop appearing ?

  • Hi there – I just started using TwentyEleven, and am making a site rather than a blog, so am trying to get the “recent posts” to stop showing up, since the pages will be mostly static. I am using the setting “Showcase Template” on the pages I am making. Seems like it shouldn’t be complicated but I just can’t find where/how to change this.

    Thanks for any help!
    drake

    http://wordpress.org/extend/themes/twentyeleven/

Viewing 13 replies - 1 through 13 (of 13 total)
  • Under Setting > Reading, you can specify a static page to use as your frontpage, instead of the recent posts.

    this didn’t do it for me. The recent posts still appear. But I am using the built in showcase template for my front page aka static page.

    Of course, that’s the way Twenty Eleven works… Is adds function, while keeping your blogposts available at your frontpage/showcase.

    You might want to read this post, as it explains how a lot of functions from Twenty Eleven/Duster work.
    The workings of Twenty Eleven / Duster

    Go into your ‘editor’.

    Find the following code in showcase template (about 3/4 way down)

    <section class="recent-posts">
    					<h1 class="showcase-heading"><?php _e( 'Recent Posts', 'twentyeleven' ); ?></h1>

    Then simply delete the part that says ‘recent posts’ (do not delete the code that says “recent-posts”>

    lizdugger

    @lizdugger

    Thanks for the info — I’m trying not to start a new topic for this “static page” problem.

    nick.kay, I tried what you show above but still have a post beneath the content.

    Just getting started on this site, but want to establish the static page before I launch into other unknown territory 🙂

    I’d really appreciate any input you can give.

    Thanks again!

    I have the same thing going on.

    My web site is mostly static. I’m using a showcase page as a static home page and posting ( very few posts ) to a static News page.

    The last post shows on the Home showcase page beneath the content. I’ve tried everything suggested here with no success. I’ve tried deleting the code relating to posts from the showcase.php template uploaded through my child theme but this breaks the site though at least something happens.

    How do I stop posts showing at the bottom of my showcase home page?

    Many thanks.

    Placing this code in index.php

    <?php
    if ( is_home() ) {
    query_posts( ‘cat=-mycat’ );
    }
    ?>

    didn’t work.

    @ nick.kay

    Thank you!!!

    I have Twenty-Eleven theme and switched each page to “Showcase Template”. I like the showcase because there is more room to display my page. I too have the “Recent Posts” on the bottom. Recently I changed some code trying to get rid of the search box and broke a link. I could not get back to my site, had someone go in and fix that. So I don’t want to change any code. Is there somewhere else I can go to get ride of the recent posts?

    Another question, the child theme? Why is this better, if I do that will I have to start over from scratch?

    esmi

    @esmi

    Forum Moderator

    Because, if you break your theme again, you will have to upload a fresh copy – which will wipe out all of your changes. Do not edit the Twenty Eleven theme. It is the default WordPress theme and having access to an unedited version of the theme is vital when dealing with a range of site issues.

    Thanks esmi, I won’t edit the theme. I tried to figure out how to do the child theme but thats way above my head. I guess I’ll have my friend do it for me.

    This isn’t a fix all for sure but as of now I had to change all of my post from standard format to aside and it got rid of it however I really don’t wont the aside format because it gets rid of my titles so there you go a quick fix until we get a permanent one.

    Deleting lines 152 to 205 in showcase.php lets the recent posts disappear, but the header shifts to the right for about 5px. So this is no option if you want your site to look good.

    Same applies to `.widget-area {display: none;}. The header will shift as well. WTF!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Theme: Twenty Eleven] How do I get "Recent Posts" to stop appearing ?’ is closed to new replies.
Skip to toolbar