Twenty Eleven
[resolved] [closed] Custom menu doesn't work on iPad (5 posts)

  1. bobk88
    Posted 4 years ago #

    I'm a newb, so please bear with me.

    I created a custom menu in Twenty Eleven. One of the menu items has two sub-menu items. The top item doesn't have a web page, so I left the URL field empty; the bottom two do have page links.

    The menu works as expected on my desktop Mac in both Safari and Firefox - hover over the menu item and the two clickable sub-menus appear. But on my iPad (with latest iOS 5), when you tap on the top-level menu item, nothing happens.

    When I tried another theme - Coraline - the menus worked correctly on the iPad - tap on the main menu item and the submenus pop up. Tap on one of the submenus, and you're taken to the proper page.

    Can anyone explain why the custom pop-up menu doesn't work on the iPad in Twenty Eleven, and if there's a simple fix?

    Thanks in advance,



  2. bobk88
    Posted 4 years ago #


    In the custom link menu, enter the pound sign # only - do not include http://.

    I'd seen something about this elsewhere, but I don't think it said to omit http://

    Sorry for the false alarm, and I hope this helps another newb like me!

  3. Judge-Mentals
    Posted 4 years ago #

    I don't think I'm entirely a noob, but your solutions helps me greatly anyway! Thanks Bob

  4. Qjoobsian
    Posted 3 years ago #

    I hope this thread is still looked at.
    I have the same usability problems on ipad.
    The submenus cannot be properly selected. The site sometimes jumps back to home.
    IE, Chrome, Safari on desktop all work well.

    I read you solution but have no clue where to look in my admin.
    Under what button do i look?

  5. WPyogi
    Forum Moderator
    Posted 3 years ago #

    @Qjoobsian - per the forum rules, please start your own thread and include a link to your site.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic