Support » Themes and Templates » [Theme: Twenty Eleven] Creating a full width page template

[Theme: Twenty Eleven] Creating a full width page template

Viewing 9 replies - 1 through 9 (of 9 total)
  • Moderator Michael


    Forum Moderator

    don’t edit the default theme Twenty Eleven directly – it is important to have an unedited defasult theme in the installation, as a fallback in case of problems.
    also, all customisations of Twenty Eleven will be overwritten with the next upgrade of your wordpress version.
    please create a child theme http://codex.wordpress.org/Child_Themes to make the edits in there.

    static pages (page.php) in twenty eleven don’t have a sidebar – so no problem there.

    you need to adapt your css; example:

    .page-template-fullwidth-php #content { width: 100%; margin: 0; }
    .page-template-fullwidth-php .entry-content, .page-template-fullwidth-php .entry-header{ width: 90%; }


    Thanks for your prompt response, alchymyth.

    Please bear with me as I’m still new to php. I tried to make a child theme by copying the TwentyEleven theme’s folder and all its contents. I read the link you gave me and only said I needed a few files (mainly just style.css), with an @importurl function. When I tried doing this, it messed up my website (error page) so I reverted back to original TwentyEleven theme and deleted the child folder. As of now, I made a copy of TwentyEleven folder in a different directory so if I mess up I’ll use that one.

    I am still confused on what I need to do to enable full width for the forum page. I’m assuming the “Default” page theme draws contents from page.php? I copy and pasted the two commands of code you wrote above into style.css but don’t really know where to go from there. Do I still need to make a separate php page for the “full width” theme? If so can you direct me in how to do so?

    Much appreciated

    Moderator Michael


    Forum Moderator

    what I need to do to enable full width for the forum page

    simply add the suggested styles into style.css of your theme.
    possibly before this line: /* error404 */

    that should be all. no need to create any other template.

    then clear the browser cache (press ‘CTRL F5’ for instance) to get the changes to show immediately in the browser.

    alchymyth I am having the same problem my site http://www.funfeat.com/programming/forum/ I also put the suggested two lines in style.css at the suggested place but no difference it makes

    please help me

    I have also done that by editing the page through admin panel and selecting “Showcase template” under attributes……Now the forum displays perfectly 🙂

    But this caused a new problem…..
    you can see that now at the bottom of the page I can see the posts of my blog. Which should obviously not appear on the forum page
    please take a look here http://www.funfeat.com/programming/forum



    Forum Moderator

    @absar: It is impolite to interrupt another poster’s thread. Please stick to your own topic.

    Moderator Michael


    Forum Moderator

    to clarify and to avoid future confusion:

    my earlier reply in this topic referred mistakenly to the styles of Twenty Ten ;-(

    I am sorry , Em new here and don’t know the forum rules…..
    @alchymyth I guess this thread was for twenty eleven :O

    @alchymyth Wonderful work! All the solutions you offer throughout all these posts are simply perfect. I must confess I’m a big fan of yours. It’s so true that whenever I face a problem with WP now (I’m a newbie), I first google putting your pseudo first… It saves me a huge amount of time and I’m sure to always apply the right fix.

    I think you’re ready to compile a book with all those brilliant tricks you offer. If you need a helping hand to translate in French, I’ll be glad to help you.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Theme: Twenty Eleven] Creating a full width page template’ is closed to new replies.