WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] theme translation doesn't work

[Resolved] theme translation doesn't work

  • thesos
    Member

    @thesos

    Hi all,

    I use a french translated WP with a french translated Brunelleschi theme.
    Problem is many pages display elements which are not translated.

    I can’t see where it comes from because I have both fr_FR.po and fr_FR.mo files in the theme’s “languages” directory.
    After opening these files with Poedit I know they contain the right sentences with appropriate translations (sentences like “This entry was posted in” ou “Primary widget area” are translated in .po file but remain untranslated as site is displayed).

    I have “define (‘WPLANG’, ‘fr_FR’);” in wp-config.php.

    So I don’t know where to look anymore … If anyone has an idea on this, it would most welcome.
    Note that website’s home page is not accessible, you could for example access website by : http://bourgogne-nepal-tibet.org/pv-dassemblees-generales/

    FYI here are the active extensions I use :
    BackWPup – GRAND FlAGallery – Image Zoom – Ultimate TinyMCE – WP Super Cache

    Thanks for your help !

Viewing 2 replies - 1 through 2 (of 2 total)
  • thesos
    Member

    @thesos

    FYI both WP and browser caches have been emptied, but problem is still here.
    Any help would be greatly appreciated.

    thesos
    Member

    @thesos

    Problem solved.
    Due to prior problems, fr_FR.mo file was modified by mistake, so I opened correct .po file and compile it with Poedit, uploaded new .mo file and translations were back

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] theme translation doesn't work’ is closed to new replies.