Support » Theme: The Erudite » [Theme: The Erudite] Erudite 3.0.2 bug – Theme Options not working

  • Resolved amethyst829


    I installed The Erudite, the WordPress theme a few days ago. Today, I got an update for it on my dashboard. After the update, I was told to install the Options plugin, which I did. Now, when I go to Theme Options to Disable Header/Footer Hiding and click on Save, it does not work. It keeps the old setting and I keep trying but it won’t let me disable this.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Theme Author Matt Wiebe


    Hmm, it works for me. Try clearing your browser cache and trying again. (It might have the old JS file still cached.)

    If that doesn’t fix it, knowing: 1) WP version and 2) which browser you’re using would be helpful.

    Thanks for the prompt response. Just cleared my cache and tried again – same thing happening.

    WordPress version: 3.3
    Google Chrome Version: 15.0.874.121 m

    Just updated to latest Chrome version 16.0.912.63 (same problem).

    Also, just tried other settings under Theme Options and none of them seem to be taking… 🙁

    I’m having exactly the same problem. I’d set it up so that my navigation would show up in the header and that my footer would display archive and more information about me, now since I’ve updated the theme, it’s all gone, so my visitors can’t navigate to old posts, and there doesn’t seem to be an option anywhere in the theme options to activate the navigation.

    (note: I’ve got the options framework plugin activated and haven’t got the newest version of wordpress, as I haven’t updated it yet. am using firefox, cleared cache and nothing seems to be working. I’m sad!)

    Theme Author Matt Wiebe


    Hey folks

    I’ve tested, on fresh installs, The Erudite 3.0.2 and Options Framework 0.9 on WP 3.1.4, 3.2.1, and 3.3. After both are installed, options are settable at Appearance → Theme Options. Under all 3 versions, checking “Turns off the dynamic show/hide functionality of the header and footer” works to disable the hiding of the header and footer.

    What likely happening is a plugin conflict. Try disabling any plugins you’re running (other than Options Framework) temporarily, and then seeing if you can set the option. Activate them one by one after that, testing.

    Provide the URL of your blog and I might be able to figure out what’s going on.

    This is happening to me. I just upgraded to the newest version of The Erudite and WordPress (3.3). I installed the Options Framework plugin. I can’t save options.

    My blog is

    I turned off all of my plugins except for Options Framework. Still can’t save the theme option settings.

    I get no errors. However, nothing changes and no boxes are checked on the theme.

    I am wondering if there is something in the Theme headers or elsewhere that needs to be hooked into the Options Framework plugin. I hope to look into it more later. Right now I have no time.

    If anyone beats me to it and figures out how to resolve this error please post it.

    Could one of you who is having issues try testing the next beta version of the plugin?

    Matt and I think it might be this issue:


    I fixed the problem by going into the database and manually flipping the switches I needed from 0 to 1. (Basically, switched it off the defaults.)

    Once I did this, I could then change settings and save my option settings fine.

    I hope that helps with any attempts to hunt down the error.

    I’ve installed the beta version, but it doesn’t change anything for me.
    I’d also taken a look at the github link first, but nothing seems to work. the erudite still won’t let me edit theme options – if boxes are ticked, they just show up blank again after the save – and this regardless of the new theme update (I was secretly hoping that it would have solved the problem..)

    my blog is here:

    with the newest wordpress install now too.

    I might try again deactivating and reactivating the plugins one by one, maybe that will help…

    has anyone figured this out yet?
    it’s making me extremely sad as the issue still hasn’t been resolved (I’ve really tried everything, I don’t know what else to do) and I will probably have to switch themes, because all my navigation and bottom menu have disappeared and it’s making it very hard for all my readers to look through past entries.
    Or install an old version of The Erudite that worked……..

    I’ll download a copy and try it after work. But, general steps to debug:

    1) Install Server Buddy and check that everything is set up correctly on your install:

    2) Make sure you have the edit_themes option. (Can you install a new theme? If so, you’re probably good)

    3) Turn off all other plugins except for the Options Panel and try saving. If it does save, it means there’s a conflict with another plugin.

    Works fine for me.

    dear devin,
    thank you! I installed serverbuddy (which anyway is a good idea to have around) and did all you suggested. the conflicting plugin was WPAudio (strangely enough though, all of my menu problems started before I installed that… anyway, who cares, now it works!)
    thank you so much. It’s bizarre because I’d already done the turning on and off of plugins and had found nothing, maybe the new update fixed it for me… (partly)

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Theme: The Erudite] Erudite 3.0.2 bug – Theme Options not working’ is closed to new replies.