WordPress.org

Forums

Buttercream
[resolved] Theme showing different logo and css to mobile devices than desktop browsers! (9 posts)

  1. techandtonic
    Member
    Posted 1 year ago #

    Hi All,
    I set up a wordpress site for a friend's bakery business. I'm using a free theme called "buttercream". I'm having an interesting issue that I cannot sort out:
    The URL is http://www.primrosebakery.com
    When the site is accessed via a desktop browser, the site I built shows up.
    When the site is accessed via a mobile device (iphone/android), the old default logo that came with the theme shows up, and the colors are different.
    I cannot figure out what is causing it to show a different version of the site to a mobile device.
    Has anyone experienced this before and can possibly point me in the right direction?

  2. WPyogi
    Forum Moderator
    Posted 1 year ago #

    Looks like you have JetPack mobile enabled. You can turn that off.

  3. techandtonic
    Member
    Posted 1 year ago #

    I had it off before, it made no difference - still showed the wrong logo. Turned it on to at least generate a mobile site that didn't show the wrong logo. Problem is, users can still click the "Show Full Site" link at the bottom of the mobile site, and then they see the full site with the wrong logo.

    I can turn off jetpack mobile site if you would like to see?

  4. WPyogi
    Forum Moderator
    Posted 1 year ago #

    Is your site on GoDaddy?

  5. techandtonic
    Member
    Posted 1 year ago #

    No, hostmonster.

  6. WPyogi
    Forum Moderator
    Posted 1 year ago #

    I just looked at your site on my iPhone and I see what you mean. Can you try deactivating JetPack AND all other plugins to see if any are causing that?

  7. techandtonic
    Member
    Posted 1 year ago #

    Sure Jetpack is now disabled.

    Look someone else was having this problem with this theme, and posted it here a long time ago. Apparently it was never resolved:

    http://wordpress.org/support/topic/theme-buttercream-cant-get-cupcake-header-to-go-away-on-mobile-site?replies=2

  8. WPyogi
    Forum Moderator
    Posted 1 year ago #

    Hmm, I just installed this theme on a test site and my custom header image works okay. Did you upload yours via the custom header option?

    Looks like maybe you modified the existing image - your file path is the same as a theme image -

    <img width="850" height="265" alt="" src="http://primrosebakery.com/wp-content/themes/buttercream/img/cupcake.png">

  9. techandtonic
    Member
    Posted 1 year ago #

    FIXED IT!

    You were right, I just saved my custom header as cupcake.png and saved it over the original. I went back and re-uploaded the original cupcake.png over it so it was back to the stock state.

    Then I saved my custom header with a new name, and went into Appearance\Header and uploaded my custom theme header image there.

    It now works perfectly on mobile devices showing the proper header image.

    THANK YOU WPyogi for all your help! THANK YOU THANK YOU THANK YOU!!!!

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic