Support » Theme: eCommerce Gem » Theme SEO error (Google Search Console error with Breadcrumb)

  • Google Search Console shows me errors in my website with breadcrumbs, that were provided by ecommerce gem theme. The error is following: unnamed item (missing field “item”), in BreadcrumbList.
    After searching thru ProDesigns forums, I realized that the issue is known/reported since September 21, 2019. I’ve tried all advised workaround methods (eg. code replacement in breadcrumbs.php file, or use new versions of breadcrumb.php file etc.) but none of the workarounds did solve the error. Please do you foresee to release some ecommerce gem theme version that will correct it (if so, please roughly when)? Or the correction has to be done by page owners individually (if so, please how?)
    My site is http://www.naturaum.ch, the theme version is 2.1.4 (newest as per 2.6.2020).
    I love your theme (its simple, nice & performing), would like to stay with it further.
    Many thanks for your feedback/advices in advance

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Please dont start with this support request yet, as the issue might be caused by other used plugin. I will further investigate and report back.

    • This reply was modified 7 months, 4 weeks ago by vasek608.

    Request can be started.
    Explanation – I deactivated & physically uninstalled Rank Math SEO plugin on staging application (to ensure that it doesn’t affect breadcrumbs anohow). The issue is still reproducible (when ecommerce gem breadcrumbs activated by “Simple”). The issue is gone when breadcrumbs deactivated (=set to “None”) in theme parameterization.

    Hello There!

    Hope you are doing good!

    Please follow the below steps to resolve the issue.

    1) Create a child theme: You can refer this page to get more details related to creating a child theme.
    2)Copy assets/vendor/breadcrumbs/breadcrumbs.php from the parent theme and paste it in the newly created child theme by following the same path as a parent theme
    3) Open the pasted file and replace line 157 to 221, by the content of the line # 163 to 251 mentioned in
    trail() on https://github.com/justintadlock/breadcrumb-trail/blob/master/inc/breadcrumbs.php

    We will cover this in our next update.

    Regards,
    Team ProDesigns

    Hello,
    your advised solution (=replace line 157 to 221, by the content of the line 163 to 251 of justintadlock’s breadcrumbs.php file) is originating from some external user advice in one of the forum posts, doesn’t work (at least not on current versions). If followed then in 2.1.5 theme version it results into uncaught error:
    https://i.imgur.com/7OvFtN5.png

    I see the 2.1.5 theme version is out recently. It actually solved the original “Missing field ‘item'” issue, but introduced another new one ‘Invalid URL in field ‘id'”:-/

    2.1.4 theme version behavior (out of the box, without any tweak):
    https://i.imgur.com/neqHuWj.jpg

    2.1.5 theme version behavior (out of the box, without any tweak):
    https://i.imgur.com/5y1pmmb.jpg

    So 2.1.5 is a bit better but sill causing SEO errors. Quite unfortunate is that these SEO issues are happening on current versions of all your themes, even on paid ones:-/

    Did you please manage to get some of your theme’s breadcrumbs running on google structured data analysis tool running without error? If so, could you please provide some link to product page where it works? Many thanks.

    • This reply was modified 6 months, 3 weeks ago by vasek608.
    • This reply was modified 6 months, 3 weeks ago by vasek608.
    • This reply was modified 6 months, 3 weeks ago by vasek608.
    • This reply was modified 6 months, 3 weeks ago by vasek608.
    • This reply was modified 6 months, 3 weeks ago by vasek608.
    vasek608

    (@vasek608)

    For other users:
    the topic was also discussed here – https://www.prodesigns.com/wordpress-themes/support/topic/breadcrumbs-missing-field-item

    Advised temporary solution (as proposed by the theme creator) works ok, requires certain field/code modification (but quite easily doable).
    I guess the proper solution will arrive with some future theme release, so nothing else expected from support about this point till then.
    Many thank!

    • This reply was modified 4 months ago by vasek608.
Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.