WordPress.org

Forums

RedBel
[resolved] Subscribe button overruns sidebar (12 posts)

  1. wilro09
    Member
    Posted 3 years ago #

    I am using the JetPack Subscribe widget in my sidebar. The image for the "submit" button overruns the width of the sidebar.

    http://wordpress.org/extend/themes/redbel/

  2. WPyogi
    Forum Moderator
    Posted 3 years ago #

    You'll need to post a link to your site so someone can see the problem and the code...

  3. wilro09
    Member
    Posted 3 years ago #

  4. thorshammer
    Member
    Posted 3 years ago #

    Yes, this is a bit of a short-coming for the RedBel theme: the default width for the SUBMIT button is 258px - which pretty much assumes it is used in the body.

    To fix this, edit the STYLE.CSS document as follows:

    .input-submit, input#submit {
    	width:258px;

    Change that width value from 258px to about 160px - that should accommodate the sidebar width. Note that this will change the "Submit" button wherever it occurs in your website.

  5. wilro09
    Member
    Posted 3 years ago #

    This "clips" the image rather "stretch/reduce" it.

  6. thorshammer
    Member
    Posted 3 years ago #

    Okay, I've created an edited version of that graphic, designed for a .input-submit element of 188px. So...
    1) edit that style to set the width to 188;
    2) get the edited sprite (graphic) here:
    http://www.asgardforge.com/submit-miracle.png (use right-click/save)

    That image needs to be renamed to submit.png, and placed in your RedBel theme's /images folder. (First move the one that's already there to another location, as a fall-back.) Let me know when that's done.

  7. wilro09
    Member
    Posted 3 years ago #

    Thank you. That looks great!

  8. thorshammer
    Member
    Posted 3 years ago #

    Sure thing.
    (Maybe mark this as "resolved"...)

  9. wilro09
    Member
    Posted 3 years ago #

    This smaller button works fine for me. I don't generally put a lot of text on my buttons.

  10. thorshammer
    Member
    Posted 3 years ago #

    Ummm.... ??

    (I was referring to marking your thread here as "resolved" - button below on this page)

  11. wilro09
    Member
    Posted 3 years ago #

    I thought I did. I'll try again!

  12. wilro09
    Member
    Posted 3 years ago #

    The resolved button on the right works. ;)

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic