Support » Fixing WordPress » Theme preview and admin bar not working when WordPress has it's own directory

  • Hello,

    I have followed these instructions: http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory so that WordPress files are tucked away in a folder not cluttering up the top-level domain.

    However, I now find that I can now not preview the themes. It just shows the current theme for all previews.

    Also the admin bar does not work when previewing at the front end (eg. can see when viewing domain.com/wordpress, but not under domain.com).

    Can anyone tell me how I might fix this?

    Thanks.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Wish I could answer this. Just want to say I have the same problem. I cannot see the admin bar on the site now that I gave WordPress its own directory.

    esmi

    (@esmi)

    Forum Moderator

    I have a number of installs in their own directories on different sites and different servers. None of them have any problems with theme previews or the admin bar.

    After about a week my admin bar has suddenly appeared. Very strange. The only change I made during this time was to change my database user name and password, and upload a new wp_config with the new database information. I suppose there might have been something wrong with my wp_config before, and when I uploaded the new one it fixed the problem. But this is only speculation on my part. I have no idea what part of WordPress creates the admin bar.

    For me, resetting my browser was the key to the missing admin bar.

    I had been logged in before I moved the site to a different directory, then made the directory change when the website went live that afternoon. The admin bar disappeared. When I read that yours had suddenly shown back up after about a week, I expected it was due to cookies expiring. I reset Safari, and I am able to see the admin bar again.

    Not sure about the theme preview issue, however. I haven’t run into that.

    I had the same issue with admin bar. As goneamiss said clearing cookies from browser cache solved it.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Theme preview and admin bar not working when WordPress has it's own directory’ is closed to new replies.