Support » Plugin: Elementor Page Builder » Theme Prerequesites for Elementor

  • Hello!

    Thanks for this great plugin!

    I have some troubles with my theme. Everything tested with Elementor works, except adding and changing images. The modal from the media library opens, but it is blank. I got some JS error. It is a Bootstrap theme with the newest Bootstrap version included.
    What does a theme need to work with Elementor? Can you help me with this error?

    Thanks in advance!

    Heiko

    Text and image below is the same error:

    JQMIGRATE: Migrate is installed, version 1.4.1
    backbone.marionette.min.js?ver=2.4.5:22 Uncaught constructormessage: "Could not find template: "#tmpl-elementor-repeater-row""name: "NoTemplateError"stack: "NoTemplateError: Could not find template: "#tmpl-elementor-repeater-row"↵    at f.TemplateCache.loadTemplate (http://www.mysite.com/wp-content/plugins/elementor/assets/lib/backbone/backbone.marionette.min.js?ver=2.4.5:22:17429)↵    at f.TemplateCache.load (http://www.mysite.com/wp-content/plugins/elementor/assets/lib/backbone/backbone.marionette.min.js?ver=2.4.5:22:17260)↵    at Function.get (http://www.mysite.com/wp-content/plugins/elementor/assets/lib/backbone/backbone.marionette.min.js?ver=2.4.5:22:16989)↵    at Object.94.elementor-behaviors/inner-tabs (http://www.mysite.com/wp-content/plugins/elementor/assets/js/editor.min.js?ver=1.2.3:5:27666)↵    at e (http://www.mysite.com/wp-content/plugins/elementor/assets/js/editor.min.js?ver=1.2.3:2:254)↵    at http://www.mysite.com/wp-content/plugins/elementor/assets/js/editor.min.js?ver=1.2.3:2:305↵    at Object.95.elementor-views/controls/base (http://www.mysite.com/wp-content/plugins/elementor/assets/js/editor.min.js?ver=1.2.3:5:29615)↵    at e (http://www.mysite.com/wp-content/plugins/elementor/assets/js/editor.min.js?ver=1.2.3:2:254)↵    at http://www.mysite.com/wp-content/plugins/elementor/assets/js/editor.min.js?ver=1.2.3:2:305↵    at Object.32.../utils/hooks (http://www.mysite.com/wp-content/plugins/elementor/assets/js/editor.min.js?ver=1.2.3:2:29833)"__proto__: Error
    jquery-migrate.min.js?ver=1.4.1:2 JQMIGRATE: Migrate is installed, version 1.4.1
    dialog.min.js?ver=3.0.2:3 Uncaught TypeError: Cannot read property 'extend' of undefined
        at Object.createWidgetType (dialog.min.js?ver=3.0.2:3)
        at Object.addWidgetType (dialog.min.js?ver=3.0.2:3)
        at dialog.min.js?ver=3.0.2:3
        at dialog.min.js?ver=3.0.2:3
    00
    Love using Elementor? Join our growing community of Elementor developers: https://github.com/pojome/elementor
    jquery-migrate.min.js?ver=1.4.1:2 JQMIGRATE: Migrate is installed, version 1.4.1
    logo.png Failed to load resource: the server responded with a status of 404 (Not Found)

    Elementor Page Builder: Can not change or add images

    • This topic was modified 2 years, 8 months ago by  Matthew.
    • This topic was modified 2 years, 8 months ago by  Matthew. Reason: added code tag
Viewing 1 replies (of 1 total)
  • Hello!

    I do not see, how to edit my post. So thanks, Matthew!

    I discovered what causes the errors. The problem discribed above occurs because I moved all script to my page’s bottom. If I let them in the usual place, everything works fine.

    I would like to have scripts at the bottom of my page but for now I have to let them in place until I found out how to do this in combination with a working EPB.

    Maybe this helps with similar problems.

    Heiko

Viewing 1 replies (of 1 total)
  • The topic ‘Theme Prerequesites for Elementor’ is closed to new replies.