WordPress.org

Forums

Theme Photocrati Crashing site (5 posts)

  1. Traveltech
    Member
    Posted 2 years ago #

    Hello. I'm tying to set up a theme named Photocrati vs. 4.5.1 into a subdirectory with a WordPress installation. Hosted on Godaddy with the latest version of WordPress. This theme worked fine until I updated to the latest WordPress version and then updated to the latest Photocrati version. After the update I get the following errors when trying to login to wp-admin.

    Warning: session_start() [function.session-start]: open(/var/chroot/home/content/63/5053363/tmp/sess_1t71kqqnodkd2tv1ov86aoa6h1, O_RDWR) failed: No such file or directory (2) in /home/content/63/5053363/html/inscribe/wp-content/themes/photocrati-theme/photocrati-gallery/ecommerce.php on line 10
    
    Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /home/content/63/5053363/html/inscribe/wp-content/themes/photocrati-theme/photocrati-gallery/ecommerce.php:10) in /home/content/63/5053363/html/inscribe/wp-content/themes/photocrati-theme/photocrati-gallery/ecommerce.php on line 10
    
    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/content/63/5053363/html/inscribe/wp-content/themes/photocrati-theme/photocrati-gallery/ecommerce.php:10) in /home/content/63/5053363/html/inscribe/wp-content/themes/photocrati-theme/photocrati-gallery/ecommerce.php on line 10
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/content/63/5053363/html/inscribe/wp-content/themes/photocrati-theme/photocrati-gallery/ecommerce.php:10) in /home/content/63/5053363/html/inscribe/wp-login.php on line 368
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/content/63/5053363/html/inscribe/wp-content/themes/photocrati-theme/photocrati-gallery/ecommerce.php:10) in /home/content/63/5053363/html/inscribe/wp-login.php on line 380
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/content/63/5053363/html/inscribe/wp-content/themes/photocrati-theme/photocrati-gallery/ecommerce.php:10) in /home/content/63/5053363/html/inscribe/wp-login.php on line 382
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/content/63/5053363/html/inscribe/wp-content/themes/photocrati-theme/photocrati-gallery/ecommerce.php:10) in /home/content/63/5053363/html/inscribe/wp-includes/pluggable.php on line 680
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/content/63/5053363/html/inscribe/wp-content/themes/photocrati-theme/photocrati-gallery/ecommerce.php:10) in /home/content/63/5053363/html/inscribe/wp-includes/pluggable.php on line 681
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/content/63/5053363/html/inscribe/wp-content/themes/photocrati-theme/photocrati-gallery/ecommerce.php:10) in /home/content/63/5053363/html/inscribe/wp-includes/pluggable.php on line 682
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/content/63/5053363/html/inscribe/wp-content/themes/photocrati-theme/photocrati-gallery/ecommerce.php:10) in /home/content/63/5053363/html/inscribe/wp-includes/pluggable.php on line 684
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/content/63/5053363/html/inscribe/wp-content/themes/photocrati-theme/photocrati-gallery/ecommerce.php:10) in /home/content/63/5053363/html/inscribe/wp-includes/pluggable.php on line 876
    
    Warning: Unknown: open(/var/chroot/home/content/63/5053363/tmp/sess_1t71kqqnodkd2tv1ov86aoa6h1, O_RDWR) failed: No such file or directory (2) in Unknown on line 0
    
    Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct () in Unknown on line 0

    I disabled all plugins before the update.
    I can go into GoDaddy and comment out the entire code of the ecommerce.php file and that stops the errors but that is not a solution that is desirable.

    If someone can shed some lite on this I would appreciate it.
    I am the ping pong ball between Photocrati and GoDaddy with each swatting be back to the other.

    Thanks

  2. There is a lot going on there. Let's start with the (possibly) easiest one.

    Give this a read.

    http://codex.wordpress.org/FAQ_Troubleshooting#How_do_I_solve_the_Headers_already_sent_warning_problem.3F

    It looks like there may be a problem with this file wp-content/themes/photocrati-gallery/ecommerce.php but it is sometimes a space at the bottom of your wp-config.php file. Is that file part of your theme or was it an add-on?

    Start by backing up the whole works as a just in case.

    http://codex.wordpress.org/WordPress_Backups
    http://codex.wordpress.org/Backing_Up_Your_Database
    http://codex.wordpress.org/Restoring_Your_Database_From_Backup

    Once you have that full backup safely stored somewhere (really, do that step) then delete the whole photocrati-theme directory. Then re-upload a fresh copy from the theme vendor's site.

    See if that resolves the issue for you.

  3. Traveltech
    Member
    Posted 2 years ago #

    Thanks for the reply.
    I did download the ecommerce.php file and there was a space at the closing of the php code. Having ridding the file of that I uploaded and reloaded with the same result.

    I then deleted the theme folder and uploaded a fresh theme, with still the same result.

    The ecommerce.php file is a file included with the theme and not an add on.
    Any other suggestions are welcome.

  4. msdukat
    Member
    Posted 1 year ago #

    I'm a beginner who has made a stupid error - I would so appreciate the help of anyone who could help me get my site back up. Please!

    I added a line of code to my functions.php to get automatic thumbnails on my blog page. This is the instruction I followed:

    "
    To add thumbnail support for all post types, append this command somewhere after the opening <php:

    add_theme_support('post-thumbnails');
    "

    Stupidly, I added a colon after the entry line <php

    Now the message I get is
    Parse error: syntax error, unexpected ':' in /home/content/69/9370669/html/wp-content/themes/photocrati-theme/functions.php on line 1

    I've tried to remove the colon and the line of code I pasted, but the error remains when I click "update file" and the message appears on my whole website http://www.dukatphotos.com

    Can anyone help. I'm desperate and promise to never edit these files again...EVER!

    Angela

  5. WPyogi
    Forum Moderator
    Posted 1 year ago #

    @msdukat - this thread is quite outdated, and since you're using a commercial theme, you need to ask photocrati for help with this. Or try using FTP to replace that file.

Topic Closed

This topic has been closed to new replies.

About this Topic