WordPress.org

Support

Support » Themes and Templates » P2 » [Resolved] [Theme: P2] Whoops! Looks like you are not connected to the server.

[Resolved] [Theme: P2] Whoops! Looks like you are not connected to the server.

  • I just started getting this error message today. I have the latest version of the theme (1.3.2). I found a previous thread here which addresses this problem. The recommendation is open header.php and replace…

    <?php if ( is_singular() ) wp_enqueue_script( ‘comment-reply’ ); ?>

    with…

    <?php wp_enqueue_script( ‘comment-reply’ ); ?>

    However, my header doesn’t contain these lines so I cannot alter them.
    Any suggestions would be greatly appreciated.

    http://wordpress.org/extend/themes/p2/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Lance Willett

    @lancewillett

    Themer

    ThePick,
    The missing JavaScript call was fixed in 1.3.2 so you should only get the error message when P2 cannot connect to the server.

    Thanks for the prompt reply.

    Do you have any ideas about why P2 wouldn’t be able to connect? I’m not quite sure how to troubleshoot this problem.

    Lance Willett

    @lancewillett

    Themer

    It happens when the WP function to check if you’re logged in or out doesn’t fire. That means that the theme can’t talk to WP, which usually means some kind of internet connection issue.

    Ah! I fooled around with the htaccess file and was able to get the server connection back. Thanks for setting me on the right track. 🙂

    Lance Willett

    @lancewillett

    Themer

    Glad to hear it.

    Just to follow up (just in case anyone else encounters the same problem) it would appear that the W3 Total Cache was the problem. I deleted the W3 plugin and rebuilt the htaccess file so it looked like this:

    SetEnv PHP_VERSION 5
    # BEGIN WordPress
    
    <ifmodule mod_rewrite.c="">
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </ifmodule>
    
    # END WordPress

    So-far-so-good. I’ll marked this as resolved.

    This thread is closed – http://wordpress.org/support/topic/p2-v131-can-not-reply-on-front-page

    I still get the ‘whoops’ error, it still asks me do I want to stay on the page when posting a topic. I tried logging and logging out, doing a hard refresh, still no good. Do I need to be logged into wordpress.com to use P2? Also it’s an admin only blog, would that be an issue? Anyhow I switched back to the previous version once more.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] [Theme: P2] Whoops! Looks like you are not connected to the server.’ is closed to new replies.
Skip to toolbar