• upgrade to 4 completely destroyed my website, theme headers work no mote on Leranpress pages, filter overrode is not working. Enroll is not working, students cannot go the courses they already enrolled.

    This 4.0 is too buggy to be released to public, you guys should know better! Just look how many issues reported just in one day.

    how to roll back after DB upgrade? You should provide work-throw here immediately

Viewing 15 replies - 1 through 15 (of 22 total)
  • Same issue here – months of my work are practically thrown away.

    How could you guys make such drastic changes knowing that they will critically affect all existing websites and courses??

    The only solution I see for now is to restore the last backup from before the update and keep using v3 until all the bugs are fixed.

    Thread Starter Vladinator

    (@alexpty)

    doing restore now, 2 weeks of work wiped off, not to mention hustle to communicate with the paid customers.

    please remove this update from WP repository before you start facing legal issues

    Plugin Support brianvu-tp

    (@briantp)

    Hi,

    To override template in the theme, you can use filter:
    add_filter( 'learn-press/override-templates', function(){ return true; } );
    to function.php in your theme. View detail change here

    Thread Starter Vladinator

    (@alexpty)

    it doesn’t work as i wrote in a header of this post, at least with my theme. An i know you will tell me to contact theme developer, but it’s the same theme i used for LP3

    update should not break commercial website, no matter that you say, so fix it please

    Thread Starter Vladinator

    (@alexpty)

    Update: Enrolled student cannot access courses anymore. we are getting up to 6 messages that students are enrolled now

    Thread Starter Vladinator

    (@alexpty)

    Update: Woocommerce payment integration is not working anymore. do you want me to start new threads? cause i have 6 more bugs now.

    Awefull job, guys, just insane

    Thread Starter Vladinator

    (@alexpty)

    Update: no headers and menu on new LP generated pages

    Thread Starter Vladinator

    (@alexpty)

    Update: cannot add new lessons to existing course anymore

    Thread Starter Vladinator

    (@alexpty)

    Update: all SEO and permanink URL are changed as per This LP4 Documentation

    Are you people for real????

    Plugin Author ThimPress

    (@thimpress)

    Hi Vladinator,

    Sorry about inconvenience. We’re still hard working for the product better. It is a product free, but we’ll make it to the best. On again, so sorry about problem with your site.

    Now, you can answer some questions. So we can know why your site has errors.

    1. Are you read term and backup site before upgrade?
    2. On progress upgrade DB on LP. Did you upgrade success?
    3. What is the LP version you installed?

    Before release LP, we public 3 version beta for user can check test. The best you should create a site stagging, try update new version and run before install that for live site.

    Thanks.

    Plugin Support brianvu-tp

    (@briantp)

    Hi @alexpty @elina61

    Which theme do you use? LearnPress 4.0 is the big update and we have a message for two months before with three beta version for all customer, developer or 3rd party update before release. LearnPress 4.0 have changed the template, database and etc.
    You can see the detail change here:
    Beta 1
    Beta 2
    Beta 3
    – All change for developer

    Thread Starter Vladinator

    (@alexpty)

    i am not a developer, i am a licensed LP user, your updates should not break my website for any reason, i just lost $1000s on refunds, because paid users cannot access courses.

    i reported your update to WordPress as a hostile

    Plugin Support brianvu-tp

    (@briantp)

    Hi @alexpty,

    Sorry to hear that, can you tell me which Theme do you use?. Theme developer should upgrade to compatible with LearnPress 4.

    Anyway, please give us more info about the Theme, we will try to help you resolve issues asap.

    Thanks,

    Thread Starter Vladinator

    (@alexpty)

    i am using 5 different themes for different sites, how do you think theme developers would know about your updates?

    do you state anywhere that LP only compatible with the certain themes?

    Plugin Support brianvu-tp

    (@briantp)

    Can you tell us more about the detail of each theme(name, author, version…)?

    We will check to guide you to fix it or provide a way to resolve it then you can contact the author of your theme to update the theme to compatible with LearnPress 4.

    We had public information about the new upgrade LearnPress 4 to our website and published beta 1, beta 2, beta 3 to wordpress.org months before the public date.

    Thanks,

    • This reply was modified 2 years, 11 months ago by brianvu-tp.
Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Theme override is not working, too many bugs in 4.0’ is closed to new replies.