WordPress.org

Support

Support » Plugins and Hacks » theme options don’t update/record

theme options don’t update/record

  • I’m a developer of a theme, wpfolio and I’ve heard a couple reports from users that the theme options with our latest release don’t update when they save. Personally I haven’t had this problem, so it’s difficult to troubleshoot. Is there something I’m missing? The code is all available here:
    http://github.com/slambert/WPFolio/blob/master/functions.php
    Theme Options start at line 329

    On a related note, it was suggested that instead of saving theme options individually they can be saved as one WP option, using an array. This is a little beyond my knowledge. Any suggestions for code?

Viewing 15 replies - 1 through 15 (of 21 total)
  • Was using Google Chrome browser with WordPress 3.0 and WPFolio 1.5.2b, and the theme options wouldn’t update. Finally….tried Internet Explorer and all worked fine. Previous versions worked with Chrome, but it’s obviously not supported now.

    thanks

    I’m having this problem (or a similar problem) myself. I just downloaded & installed WPFolio 1.7 and am currently using the included child theme, but I should mention that I was unable to save changes to my theme options even when version 1.5 was installed.

    Specifically, here’s what is happening: I am getting an error specific to the Page Container Color option. The error says that Page Container Color is an “invalid value” even though I have never changed it and it is set to the default FFFFFF. If I try to change it to something else, I get the same error. And if I try to change any other field, I am unable to save my changes because of this error.

    Not sure what to do from here — haven’t been able to find any solution (or example of anyone else with the same problem) in the WPFolio wiki or in the codex.

    weird. Check if you can upload a background. If yes, then…

    try deleting WPFolio entirely and reinstalling, just to make sure you don’t have lingering versions of the files. I’m not sure that’s it, but I have had a few people who thought they updated and didn’t get every file.

    If no, try uploading a background with twentyten.

    I was able to upload a background, so I deleted WPFolio and reinstalled as you suggested. I made sure all WPFolio files were gone before reinstalling. The problem persists.

    Another observation about the problem: The theme option default for text is Arial, sans-serif, however the text on my site is displayed as a seriffed font. The strange thing is that this renders correctly for me with 1.5, but not with 1.7.

    the font stack changed between those versions.

    Hm… this sounds like some kind of database hiccup.

    If you don’t mind being my guinea pig (I can’t test this myself and don’t know how to create the error) change the name of wpfolio in the theme’s style.css folder. If that doesn’t work, try changing the name of the folder as well.

    I’m thinking if we can change how WP recognizes the theme, and it works, then that means there’s some corrupt data (would love to know why) in the database connected to your install of WPFolio.

    Hmm, not exactly sure what you’re asking me to test out. My folders look like this: wp-content > themes > wpfolio > styles.css. There is no “style.css folder” just the style.css file itself. Are you suggesting I change the name of the wpfolio directory that contains styles.css? I tried that and it broke the theme and my site reverted to Twenty Ten.

    I guess I could solve the problem by bypassing the theme options menu and overwriting the stylesheet with my font & color choices. Kinda defeats the purpose of using a child theme though.

    Sorry, I meant change the name in the style.css file. Something like

    FROM:
    Theme Name: WPFolio

    TO:
    Theme Name: WPFoliooooooooo

    I changed the name to WPFoliolio and it didn’t have any effect on my inability to change theme options. I’m at a total loss. I would just go back to wpfolio 1.5, but I wasn’t able to change theme options in that version either.

    Thanks anyway. I’m subscribed to this thread, so if anyone suggests any ideas, I’ll be sure to give’em a try.

    Looked at this for a bit and it seems like a conflict with Chrome. I can edit the Theme Options successfully in Firefox or Safari and they will show up in Chrome fine, but that ‘Invalid Value’ error comes up as soon as you try to edit any of the Theme Options in Chrome.

    Tried this with a child theme and parent WPFolio 1.7.11 with WP 3.1.

    A key clue in solving this mystery!

    notlaura, I think you’re right! I’m using Firefox now and the problem seems to be gone. Don’t know why it doesn’t work with Chrome.

    Hm, I just tried to replicate this in Chrome on a mac and didn’t see the error…

    It’s still happening for me (also Mac). Did you hit save? That’s when the error shows up.

    yup…

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘theme options don’t update/record’ is closed to new replies.
Skip to toolbar