Support » Fixing WordPress » Theme not working locally

  • I have LAMP up and running. I created a wordpress theme and installed it without permission issues on my local server (on the folder /var/www/wordpress). But when I’m trying to run it or preview it, I get a blank page. If I check the source code of the blank page, it’s completely blank.

    But this only happens locally. I tried to upload it to an online server and everything worked ok. First I thought it was permissions issue but I have the same ones as the other themes – that work without problems.

    As you can see, the permissions for my theme are:

    and the permissions for the other templates are:


Viewing 5 replies - 1 through 5 (of 5 total)
  • wpismypuppet


    If it’s blank, it might be a PHP error happening locally. Try looking at your LAMP error logs. Perhaps you don’t have your PHP’s ini file configured properly? Hard to tell… but a completely white screen, in my experience, means there’s a fatal PHP error and you have errors suppressed in your ini file so you aren’t seeing the error. The log will tell all.

    You say you created a theme.

    Does this also happen locally with the default WordPress theme?

    @wpismypuppet How do I see the log?

    @mike, No, only with my theme (and only locally).

    ok, so that is a good sign.

    wpismypuppet has a point, by enabling wp_debug you can see if you have any errors or warnings locally.

    read more about debugging in WordPress here:

    Ok, I really though I submitted this but I just want to let you know that with the wp_debug I was able to trace the bug and it was a syntax error (I forgot a ‘?’ in <?php …

    SO thank you!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Theme not working locally’ is closed to new replies.