Support » Themes and Templates » Theme not showing tag line

  • Hi,

    I have installed gazpoMag theme. I put a tag line in setting-> general-> tag-line, but it doesn’t show up. Blog only shows blog title.

    I would really appreciate if anyone can help please!

    Thanks

Viewing 13 replies - 1 through 13 (of 13 total)
  • Here is the link:
    gazpoMag
    Please let me know which files I have to edit as it seems theme doesn’t support tag line. I do want to use this theme so please tell me the solution.

    Thanks

    Have posted another thread. So, closing this one.

    Moderator Andrew Nevins

    (@anevins)

    Forum moderator

    Duplicating threads is not necessary.
    Continue on this thread.

    Got no reply on this one so posted another one. I have already posted anther thread with a bunch of code, so what should I now?

    Moderator Andrew Nevins

    (@anevins)

    Forum moderator

    Post that code on here, your duplicated thread will be closed.
    As this forum is entirely contributed by forum volunteers, it’s common for threads to be unanswered for tens of hours.
    If your issue is urgent, consider hiring a developer.

    Here is the link to the other thread. Can you please take a look and provide any help?

    Moderator Andrew Nevins

    (@anevins)

    Forum moderator

    It’s confusing for volunteers to follow two threads of the same issue.
    Can you post the code into this thread?

    Sure, here it is:

    <!DOCTYPE HTML>
    <?php include( TEMPLATEPATH . '/includes/get_options.php' ); ?>
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    	<title><?php bloginfo('name'); ?><?php wp_title(); ?></title>
    	<?php if($gazpo_favicon_url){ ?>
    	<link rel="shortcut icon" href="<?php echo ($gazpo_favicon_url); ?>" />
    	<?php } ?>
    	<meta http-equiv="Content-Type" content="<?php bloginfo('html_type'); ?>; charset=<?php bloginfo('charset'); ?>" />
    	<link rel="profile" href="http://gmpg.org/xfn/11" />
    	<link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" type="text/css" media="screen" />
    
    	<link rel="alternate" type="application/rss+xml" title="<?php bloginfo('name'); ?> RSS Feeds" href="<?php if ($gazpo_rss_url) { echo $gazpo_rss_link; } else { bloginfo('rss2_url'); } ?>" />
    
    	<link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="<?php bloginfo('atom_url'); ?>" />
    	<link rel="pingback" href="<?php bloginfo('pingback_url'); ?>" />
    	<link href="http://fonts.googleapis.com/css?family=Droid+Serif:regular,italic,bold" rel="stylesheet" type='text/css' />
    
    	<?php if ( is_singular() ) wp_enqueue_script( 'comment-reply' ); ?>
    	<?php wp_head(); ?>
    
    </head>
    <body>
    
    <div id="header">
    <div class="wrap">
    	<div class = "logo">
    		<?php if ($gazpo_logo_url){ ?>
    		<a href="<?php bloginfo('siteurl');?>/" title="<?php bloginfo('name');?>">
    			<img src="<?php echo $gazpo_logo_url; ?>" alt="<?php bloginfo( 'name' ); ?>" />
    		</a>
    		<?php }else {?>
    		<div class="text">
              <h1><a href="<?php bloginfo('siteurl');?>/" title="<?php bloginfo('name');?>"><?php bloginfo('name');?></a></h1>
            </div>
    		<?php } ?>
    	</div>
    	<div class = "right">
    		<div class = "header-menu">
    			<?php wp_nav_menu( array(
    					'container' => false,
    					'theme_location' => 'header_menu'
    				) );
    			?>
    		</div>
    		<?php
    		if ($gazpo_twitter_username){ ?>
    
    		<div class = "twitter">
    			<ul id="twitter_update_list"><li>&nbsp;</li></ul>
    		</div>
    
    		<?php } ?>
    	</div>
    </div>
    
    </div>
    
    <div id="subheader">
    <div class="wrap">
    	<div class="main-menu">
    		<?php wp_nav_menu( array(
    					'container' => false,
    					'theme_location' => 'main_menu'
    				) );
    		?>
    	</div>
    	<div class="search">
    		<?php $search_text = "Search"; ?>
    			<form method="get" id="searchform" action="<?php bloginfo('url'); ?>/">
    				<input class="searchfield" type="text" value="<?php echo $search_text; ?>" name="s" id="s" onblur="if (this.value == '') {this.value = '<?php echo $search_text; ?>';}" onfocus="if (this.value == '<?php echo $search_text; ?>') {this.value = '';}" />
    				<input type="hidden" id="searchsubmit" />
    			</form>
    	</div>
    </div>
    </div>
    
    <div id="container">
    Moderator Andrew Nevins

    (@anevins)

    Forum moderator

    Look at the code that displays the blog title. You need to add code to display the tagline.
    An example can be found on this resource
    http://codex.wordpress.org/Function_Reference/bloginfo#Show_Blog_Description

    Hi Andrew,

    Thanks for sharing the resource. But this is what I have seen earlier on some other threads and couldn’t find this line in my header file. I don’t know much about wordpress coding so can you please take a look at my code and explain which lines I have to edit and what I have to put in place of them.

    Thanks

    Hi Andrew,

    Is this the concerned line of code:
    <title><?php bloginfo('name'); ?><?php wp_title(); ?></title>

    I just replaced “name” with description in the above line but now blog title has disappeared from the tab and it only shows description line.

    Moderator Andrew Nevins

    (@anevins)

    Forum moderator

    Make sure you add the code, rather than replace.
    So you need something like;

    <title><?php bloginfo('name'); ?><?php wp_title();  bloginfo('description'); ?></title>

    [not resolved, but topic closed as duplicate; to avoid confusion, continue at http://wordpress.org/support/topic/how-to-add-tag-line-any-help?replies=5 ]

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Theme not showing tag line’ is closed to new replies.