Support » Fixing WordPress » Theme not loading completely?

  • Resolved csl749


    Hi folks – wondering if you could help me with this little problem I’m having. Basically, half the time I load up my site the theme doesn’t load properly, stopping halfway through. The header image and main page backgrounds load down to where the meta heading should be on the sidebar, but the meta section doesn’t load, and nor does the rest of the main page background or footer. The text etc does load
    properly, though.

    This doesn’t seem to be a consistent problem, either, sometimes it loads up coempletely, other times stalls as above. I’m running the following problems in WP 2.2, but have disabled them all to try and locate the problem, yet the problem still occurs, even with all plugins disabled.

    Adhesive 3.2
    Akismet 2.0.2
    bbPress Integration 0.74
    BBpress Latest Discussions 0.9
    Brian’s Threaded Comments 1.5.12
    Dagon Design Form Mailer 4.21
    Event Calendar 3.1.1._rc1
    Event Calendar Widget 3.1.1._rc1
    Get Recent Comments 1.5.5
    Google Sitemaps 2.7.1
    Gregarious 1.999
    podPress 8.1 Stats 1.0

    Here’s my blog

    Like I say, this might appear to be fine when you first visits, but refresh a few times and you’ll probably come across the same problem. Any ideas on what may be causing this instability would be hugely appreciated. Perhaps an element is timing out leading to the rest of the page loading incomplete? Thanks.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The only time it stop loading for me it look like it was hanging on the meta section of your sidebar. Check your server logs and see if there is anything usual. Also try repairing or optimizing your database, same thing just different terms for it.

    Thanks for the help JC13 – I tried optimising my DB in the past, and just did it again for good measure, but it doesn’t appear to help in this instance.

    Checked the error logs and saw this (the only error that reoccurs throughout the log):

    [error] PHP Warning: Cannot modify header information – headers already sent by (output started at /wp-includes/wp-db.php:133) in /wp-includes/feed-rss2-comments.php on line 2

    I also tried dropping the meta widget from the sidebar, but that still makes no difference.

    Aha, just found this post, which got me looking at the footer code. Since I used a modified Kubrick theme, I though I’d just update with the latest default theme footer, add my custom text and plonk it in over the top of the previous footer. Seems okay now. So all I needed to do was update my Kubrick-tweaked theme, basically.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Theme not loading completely?’ is closed to new replies.