WordPress.org

Support

Support » How-To and Troubleshooting » Theme not found when using theme-editor

Theme not found when using theme-editor

  • Hi folks
    So I did a fresh install of WordPress and then created my first ever theme and it all worked great.. but when I try to use the theme-editor inside wordpress (which I need for shear convenience!) is telling me:

    The requested theme does not exist.

    I tried changing the permissions on the folders (755,777) but nothing seems to work! help!

Viewing 14 replies - 1 through 14 (of 14 total)
  • Assuming your theme is call my-theme, then you have a folder called wp-content/themes/my-theme?

    And wp-content and wp-content/themes are 777 permissions?

    Do you have theme info in your stylesheet?

    http://codex.wordpress.org/Theme_Development

    yes to all of the above questions!

    I don’t understand why it’s not working.
    I’m pretty sure it’s not the CHMOD-ing cause I can edit the default templates no problem. 🙁

    and now it won’t even let me upload images!
    this is so strange. I’ve had wordpress working for 2 years on this server and then I upgrade and all goes to hell.

    I’m using this site as my chmoding guidelines
    http://www.tamba2.org.uk/wordpress/chmod/

    and I’ve done what it says. anyone!

    no one can help??

    Joni
    Member

    @jonimueller

    Post the top part of your stylesheet, please, the part that describes the theme.

    Then specify exactly the name of the folder that you put the theme in, the theme folder. We all know it goes in /wp-content/themes/.

    And quit being so demanding. Nothing pisses me off more. You come here for help; you aren’t paying for it. It’s a blog for crying out loud. No little children will die if this problem doesn’t get solved in an hour, a day or even a week. Maybe no one has the answer to your question or maybe no one feels like answering at that particular moment in time, you know?

    So, post the information requested and let’s see if it can be solved.

    sorry dude – I just know once posts get buried they never get solved. I’m not being demanding I’m just trying to figure out a solution to my problem.

    /*
    Theme Name: WatchingYou
    Theme URI: http://www.bigbrotheraccess.com
    Description: Custom theme for bigbrotheraccess.com
    Author: BBA
    Author URI: http://www.bigbrotheraccess.com
    Version: 1.0
    */

    Joni
    Member

    @jonimueller

    And DUDE, pay attention. It’s one of the keys to happiness:

    Then specify exactly the name of the folder that you put the theme in, the theme folder.

    So I ask again: What FOLDER is it in when you install it. Where are you putting it?

    Example:
    Theme Name: Favorite Theme

    Theme URL is: http://www.mycooldomain.com/wp-content/themes/favorite-theme/

    Joni
    Member

    @jonimueller

    Yep, I can see it in your directory. The only thing I can tell you, and this SHOULD NOT MATTER, but name your folder instead of BigBrotherAccess, WatchingYou … and see if that helps. The only other suggestion I have is to just delete the entire theme folder and start over. Sometimes servers burp and things don’t always get uploaded the way they should.

    I had already tried that before but it didn’t seem to help.

    I think I’m just gonna delete everything and upload an older version of WP. Cause image uploading doesn’t want to work and I didn’t have this problem on the old versions.

    Joni
    Member

    @jonimueller

    Then you’ll want to go back to 2.0.11, because besides 2.5.1, it’s the only other supported, secure version. Good luck.

    so it must be my layout.
    cause the upload thing works now.. but same issue with the theme editor.

    im sad

    okay so I didn’t figure out the template-editor yet
    but I disabled the flash upload and the uploading works fine now!

    but when I click “add to post” it gives me a internal server error. Anyone know what the deal now?

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Theme not found when using theme-editor’ is closed to new replies.