Support » Theme: Modern » Theme no longer mobile friendly

  • Resolved igtqb0

    (@igtqb0)


    Since Jetpack removed its mobile friendly support, Google Console shows the theme is no longer mobile friendly:
    • Clickable elements too close together
    • Content wider than screen
    • Text too small to read

    Is their an easy fix?

Viewing 5 replies - 1 through 5 (of 5 total)
  • I had the same issue and only comment to get notifications of other comments.

    Theme Author WebMan Design | Oliver Juhas

    (@webmandesign)

    Hi,

    Please note that the theme is responsive out of the box and it does not contain such issues on its own. There is no need to use Jetpack plugin’s mobile theme. Actually, every WordPress theme available for free via WordPress theme repository has to be responsive/mobile friendly out of the box.

    Could you provide URL to affected page so I can check personally? Does Google provide your with specific elements on your page that are causing the issue? This is most likely an issue with a website content, not the theme (unless you’ve set small font size in theme options, for example).

    Also, please note that I provide official support at https://support.webmandesign.eu/

    Thanks and regards,

    Oliver

    Hi Oliver,

    Here is a link to one of the pages, which I’m told is no longer mobile friendly: https://ceredigionhistory.wales/penbryn-history/

    I hope there is an easy solution?

    Thanks for looking!

    Mmm … on checking this again its saying it is now mobile friendly, thought I have not made any updates?

    This page says still says it has an issue: https://ceredigionhistory.wales/llanon/

    Thanks again!

    Theme Author WebMan Design | Oliver Juhas

    (@webmandesign)

    Hi,

    I’ve checked your website and I can see no horizontal scroll on mobile screens. So, I’m not sure why Google complains about “Content wider than screen”.

    As for small text and clickable elements too close together, I think it might be related to your cookie consent popup. It contains some small text and even covers the mobile navigation button. Try to disable the plugin providing this functionality and test the page again with Google. Once you know the issue is related to your cookie consent, you can take further steps from there.

    As for clickable element too close together, maybe even the last section “See:” in the page content might be problematic for Google? If so, try to use some other solution.

    But I wouldn’t really look at Google’s report if your page is usable on mobile devices. You know, Google is only robot and I was a witness of many false positives in the past… Besides, from what I understand the Google Console didn’t provide you with specific information what page element is causing which issue…

    Best regards,

    Oliver

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Theme no longer mobile friendly’ is closed to new replies.