Support » Themes and Templates » Theme mysteriously disappeared in "available themes"

  • I’ve been learning my way around wordpress by building my own child-theme of Thematic. Everything had been working for a while… I went to change the template used by some of the pages (which I had success with in the past), but suddenly only “default template” was showing in the dropdown.

    I figured out that this was because it had somehow reverted to the TwentyEleven theme, but worse than that: my own custom child-theme was no longer listed under “available themes.” (I made absolutely no alterations to the file structure or the comments section of style.css; it is exactly the same as it was when everything was working fine.)

    The SUPER strange part is that my site was still displaying as if my child-theme was active!! Seriously, WHY THE FACE?! o_0 (This also makes it impossible to know when the problem occurred.)

    Unfortunately, I tried switching to Thematic, and seeing if that made my child-theme reappear as an option, which didn’t work, so now my site looks like Thematic, and I can no longer continue working on other aspects of my custom style.css until this problem is resolved.

    I tried creating a brand new child-theme, the same way I did it the first time (which had worked), and it also did not show up.

    I cannot provide a link to my site because I’m building it locally, using MAMP.

    Sure hope someone can help; thanks!

Viewing 11 replies - 1 through 11 (of 11 total)
  • No guesses? No one else experiencing this issue?

    Hope anyone in the US had a great Thanksgiving!

    I’m still totally stumped by this, and hoping someone will come along with a solution, or at least some ideas!

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading the wp-admin folder from a fresh download of WordPress.

    – repairing your database.

    Hey esmi,
    Thanks for the tips!

    – I should have explained that I have indeed deactivated all plugins, because I understand they can cause issues. I wish that had done the trick.

    – I’m attempting to follow the instructions to reset the plugins folder by PhpMyAdmin, but my understanding/experience with databases/MAMP is still very weak. I got this far (screenshot:, but there doesn’t appear to be a field/value for me to edit.

    – Just to know what I’m getting into, should I expect to need to recreate anything to do with my admin when I re-upload a fresh wp-admin folder?

    – I’m not entirely sure what repairing my database will entail either, but hopefully it won’t come to that.

    Thanks esmi; I really appreciate it!

    I figured out how to access that value for resetting the the plugins folder. (I had to switch from the “structure” tab to the “browse” tab in phpMyAdmin, and after that I had to do some searching to find “active_plugins.”)

    Unfortunately, the value was already set to “a:0:{}” so I guess all plugins must have been successfully deactivated? Just in case, I pasted “a:0:{}” over itself and hit “go” just in case this made a difference, and sadly it did not.

    I also just tried replacing the wp_admin folder with one fresh from the oven. No dice there either (and it didn’t ask me to log in or anything, so I guess maybe that answers my question about that).

    I’ll look into repairing the database, but I’m not sure how far I’ll get, so please send any hints my way if you get a chance!

    Thanks so much again for your time and knowledge!

    Hello again, folks. For the past few days I’ve been very sick, and focusing on other projects…

    I’m trying to refocus on this today, but I still haven’t found a guide to repairing a database in MAMP. If anyone can explain, or at least point me in the right direction, they would have my eternal gratitude, haha… I’m really digging blind here, since databases are not my thing… I just need to get this project back up and running.

    Thanks for the response anithaelizebath,
    As you’ll see above, esmi already recommended disabling plugins, and I had actually forgotten to explain that I had already done so myself prior to that. (I wish it was so simple…)

    I’m not sure how I could effectively re-install my theme… if removing the theme folder and putting it back counts, then I’ve already tried that (although I don’t see how that could affect anything anyway). Again, I also tried creating a brand new child-theme, and not even that would show up, so I suspect this wouldn’t do anything. *frustrated*

    Anyway, I’d love to try esmi’s final suggestion, which was “repairing your database.” I just don’t know what this entails.

    I just completely deleted all plugins (which were already disabled), except for akismet since that comes pre-installed anyway. No change.

    Still hoping someone out there can explain to me what esmi meant by “repair your database”(?)

    As a last ditch effort, I tried backing up my entire site with the EZPZ One Click Backup plugin (recommended here:, reinstalling a fresh wordpress (again locally with MAMP), and restoring the backup. I figured this might not solve anything if there was something corrupt about the database (as esmi implied)… but I ended up with a worse problem: The restoration didn’t even work… so now all of my posts and preferences are wiped. I’m lucky to still have the major work I did on my child theme… but of course, I still can’t get the theme to show up in the “available themes” panel.

    In any case, now that my database has been wiped, I don’t see how a database repair could solve anything (unless I’m misunderstanding somehow), so I guess I’ve effectively tried all of esmi’s suggestions.

    Does anyone out there have any other idea why a child theme would suddenly be incompatible with WordPress. There was no software update involved. Again, I’ve tried creating another, fresh child theme and that didn’t show up either, so I guess it must be child theme related. I’m still totally mystified.

    Any solution to this?
    A very similar thing just happened on one of my sites, after upgrading to WP 3.3.1, my child theme (of twentyten) no longer appears as an option, yet it’s still being used (all appears correct on the front end). The admin page tells me I’m using Twenty Eleven but I’m not.
    I upgraded my plug-ins, so they’re all up to date and compatible with the current WP version. Deleted one that wasn’t.
    I found other child theme problem posts and made sure my style.css file is set up correctly. (I have about 8 WP sites with child themes and they all work, this is the first site I’ve upgraded to 3.3.1).
    I think it’s a bug with the new WP?

    Just found a solution – see

    For some reason when I had downloaded my style.css file from the server (to make sure I had the latest copy of everything before upgrading) it converted the line breaks from LF to CR. When I converted them back (using NotePad++, EOL conversion to UNIX) and uploaded the file again, voila my theme is available again for activation! All is functioning normally now.


Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Theme mysteriously disappeared in "available themes"’ is closed to new replies.