Support » Theme: Museum Core » [Theme: Museum Core] Underline Hyperlinks

  • Resolved Taneya


    I am using Museum Core on a site I am working on and am having trouble editing the CSS code to make hyperlinks have an underline. I tried editing in the “Body” section of the stylesheet and add text-decoration: underline – -but that didn’t seem to work. Any ideas on what I can edit in the stylesheet to make the links have an underline?

    Thank you.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Try changing the “text-decoration: none;” to “text-decoration: underline;” in this CSS code — line 765 in style.css:

    a, a:link, a:visited { color: #486D96; }
    a:hover, a:active { color: #333333; }
    a {
      text-decoration: none;
      -webkit-transition: all 0.3s ease!important;
      -moz-transition: all 0.3s ease!important;
      -o-transition: all 0.3s ease!important;
      transition: all  0.3s ease!important;

    Do be aware that it will underline all links throughout the entire site…

    Thank you for your reply! However, I made that change and it still does not underline the links.

    Did you try clearing your browser cache? Stylesheets can sometimes be cached so changes won’t be visible. Otherwise, you’ll need to post a link to your site so someone can look at the actual code and see what’s going on.

    Yes, I did that and still no success. The site is Thanks.

    Ah, it looks like various other CSS code is overriding that general one. So add the “!important” to what you changed:

    text-decoration: underline !important;

    Theme Author Chris Reynolds


    You can use the css editor on the Advanced tab in the Theme Options to add your style rules. That gets loaded last, so it should automatically override any of the styles in the stylesheet. That way, too, you aren’t going to lose your changes when you update the theme.

    Adding the important emphasis worked! Thanks WPyogi. I’d prefer not to have the underlining in the header, but that doesn’t bother me as much as not having any of the links underlined did. 🙂

    Aww man! I completely missed the Theme Options pages. I’m using this on a network, so am so used to going directly to the network admin to edit themes so I overlooked it on the specific site installation. I will also play around with that to see if I can make the changes that way.

    Thanks to both of you!

    Theme Author Chris Reynolds


    I update the theme fairly regularly, so using the custom css option in the Theme Options page will probably be a more reliable solution than changing the code. One day I’ll put those pointers in to point to the theme options 🙂

    I am looking at the Advanced tab in the Theme Options panel now and I don’t see a Custom CSS option on the screen. I see sections for custom favicon, meta description, met author, meta generator tag, full posts or excerpts, and Twitter hovercards. Am I looking in the wrong place?

    Theme Author Chris Reynolds


    You might be using an old version. What version are you running? It was added in 1.1.1 or 1.1.2.

    Theme Author Chris Reynolds


    actually, just rechecked the changelog and it looks like that was added in 1.1. So you have 1.0.9 or earlier.

    ah great! i updated the theme and edited the custom css box. thanks!!

    Theme Author Chris Reynolds


    np 🙂

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Theme: Museum Core] Underline Hyperlinks’ is closed to new replies.