WordPress.org

Forums

Museum Core
[resolved] Comments (20 posts)

  1. anemoone
    Member
    Posted 3 years ago #

    Hello.

    I've installed the theme. I've noticed two problems.

    Comments lack commentators' names nad dates.

    The other problem was in the customizable footer (via Theme Options). The links did't link properly, so I had to unlink some words.

    http://wordpress.org/extend/themes/museum-core/

  2. Michael
    Forum Moderator
    Posted 3 years ago #

    in functions.php of the theme, nearly half-way down:
    add echo to this line (shown after the edit):

    <?php echo sprintf(__('On %1$s at %2$s %3$s said:','museum-core'), get_comment_date(), get_comment_time(), get_comment_author_link()) ?>
  3. anemoone
    Member
    Posted 3 years ago #

    Thank you.

    I've added the word. Now comments are OK.

  4. Chris Reynolds
    Member
    Theme Author

    Posted 3 years ago #

    Sorry about that guys. I didn't have emails set up on this tag yet. As soon as I get SVN access to update the theme, I'll take care of this. I think I found and fixed the customizable footer, but I'll take a look at that, too. For now, the latest version is up on GitHub. I've added these as tickets in the issue tracker there: https://github.com/jazzsequence/AP-Museum_Core

  5. Chris Reynolds
    Member
    Theme Author

    Posted 3 years ago #

    @anemoone The issue with the footer links has been found and will be fixed in the next version. For now, if you want to fix it, open footer.php and find this:

    <div class="credit">
    				<?php if ( $options['footer'] != '' ) {
    				echo $options['footer'];
    				} else {
    					echo $defaults['footer'];
    				} ?>
    			</div>

    and replace that with this

    <div class="credit">
    				<?php if ( $options['footer'] != '' ) {
    				echo stripcslashes($options['footer']);
    				} else {
    					echo $defaults['footer'];
    				} ?>
    			</div>

    That should take care of it -- there's some other stuff I'm fixing in the theme-options.php but that should resolve the root issue (assuming your links were doing what mine were, which was trying to link to http://mydomain.com/"http://mynewlink.com/")

  6. anemoone
    Member
    Posted 3 years ago #

    @Chris Reynolds

    assuming your links were doing what mine were, which was trying to link to http://mydomain.com/"http://mynewlink.com/"

    Yes, that's the same error.

    I've changed that fragment of code.
    Now it's fine. Thanks.

  7. Chris Reynolds
    Member
    Theme Author

    Posted 3 years ago #

    This will be fixed in the next version which I've uploaded today.

    Edit: ...and it's now live http://wordpress.org/extend/themes/museum-core/

  8. anemoone
    Member
    Posted 3 years ago #

    When I updated to the newest version, this warning appeared on my page:

    "Warning: sprintf() [function.sprintf]: Too few arguments in /home/anemoone/public_html/wp-content/themes/museum-core/functions.php on line 335"

    So I replaced functions.php file with the the same file from the earlier version of the theme, found in Theme SVN.

  9. Chris Reynolds
    Member
    Theme Author

    Posted 3 years ago #

    Looking now.

  10. Chris Reynolds
    Member
    Theme Author

    Posted 3 years ago #

    found it.

    Line 335 in functions.php.

    Was:

    'footer' => sprintf( __( '%1$s %2$s %3$s . ', 'museum-core' ), '©', date('Y'), get_bloginfo('title') ) . sprintf( __( 'Museum Core by %1$sMuseum Themes%2$s is proudly powered by %4$sWordPress%2$s.', 'museum-core' ), '<a href="http://museumthemes.com/" target="_blank" title="Museum Themes">', '</a>', '<a href="http://wordpress.org" target="_blank">' ),

    Should be:

    'footer' => sprintf( __( '%1$s %2$s %3$s . ', 'museum-core' ), '©', date('Y'), get_bloginfo('title') ) . sprintf( __( 'Museum Core by %1$sMuseum Themes%2$s is proudly powered by %3$sWordPress%2$s.', 'museum-core' ), '<a href="http://museumthemes.com/" target="_blank" title="Museum Themes">', '</a>', '<a href="http://wordpress.org" target="_blank">' ),

  11. Chris Reynolds
    Member
    Theme Author

    Posted 3 years ago #

    fixed in 1.0.7.2

  12. anemoone
    Member
    Posted 3 years ago #

    Installed that version. No problems.

  13. Chris Reynolds
    Member
    Theme Author

    Posted 3 years ago #

    excellent. thanks for the feedback. Helped me clean out the bugs. :)

  14. anemoone
    Member
    Posted 3 years ago #

    There's one more thing. Why pignback from my site didn't appear below the text?

    Don't know if it is the theme's fault.

    http://kratery.com/2012/04/16/smolensk-impresje/

  15. Chris Reynolds
    Member
    Theme Author

    Posted 3 years ago #

    Hm. Not sure. I'll look into it.

    Want to help out with a Polish language file for the theme?

  16. anemoone
    Member
    Posted 3 years ago #

    Want to help out with a Polish language file for the theme?

    Of course I could help, but have little experience. I translated for myself most of the words in two themes I used before (in my editor). Didn't prepare any files.

  17. Chris Reynolds
    Member
    Theme Author

    Posted 3 years ago #

    Of course I could help, but have little experience.

    That may not be a huge issue. I've got a GlotPress installation set up, just need to upload the updated files. So everything is web-based. Here's what the English language file looks like as an example:

    http://translate.museumthemes.com/projects/museum-core/en/museum-core-en_US

  18. anemoone
    Member
    Posted 3 years ago #

    Most of this is quite easy. Some SEO-related frazes need rethinkig, but I use SEO plugin, so I should manage. I'll try to start doing the translation tomorrow.

  19. Chris Reynolds
    Member
    Theme Author

    Posted 3 years ago #

    Most of it is options page stuff, with only a few strings here and there that are actually on the front end. Shoot me an email at chris at arcanepalette dot com and I can set you up with an account.

  20. Chris Reynolds
    Member
    Theme Author

    Posted 3 years ago #

    Found the trackback issue. Fixed in 1.0.8.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic