WordPress.org

Forums

[resolved] (Theme: Lucid )Navigations issue (12 posts)

  1. Uljicni
    Member
    Posted 1 year ago #

    So i am learning in procces and i wanted to use theme Lucid from elegantpress, found it online somewhere a couple of days ago.

    What i want to do is to modify top-menu and second-menu trough css but some of the styles is in (index) and i dont know how to override it, i want both menues with same link color, hoover over and active

    I tried to make child theme and just put my css but it is overriden with (index) ona line 54, or 64 so can anybody help me or explain how to do this??

    style.css on line 101 and in index

  2. stephencottontail
    Member
    Posted 1 year ago #

    I'm sorry, but as you are using a commercial WordPress theme, you need to seek support from your theme's vendor, in this case, Elegant Themes. After all, that's part of what you paid for. Here, we only support themes downloaded from the official WP.org repository.

  3. Uljicni
    Member
    Posted 1 year ago #

    no problem should i delete post?

  4. Andrew
    Forum moderator
    Posted 1 year ago #

    Might as well leave it up so that Stephen's comment has some context, but you could remove the link to your site if you don't want it there.

  5. stephencottontail
    Member
    Posted 1 year ago #

    You don't have to.

  6. Uljicni
    Member
    Posted 1 year ago #

    in general i think the best is to do child theme with css that overrides theme's css,

    i am just wondering how come when i inspect page on particular navigation it says (index): number of line cuz i've nnever seen this

  7. Andrew
    Forum moderator
    Posted 1 year ago #

    It's referring to some styling in your <head> element of the page, put there by a plugin(?)

  8. Uljicni
    Member
    Posted 1 year ago #

    probably cuz theme ofers color schemes (3 colors) and u have to pick one , u can not disable it, everything else i can disable, heh

  9. Andrew
    Forum moderator
    Posted 1 year ago #

    If you're using more specific selectors in CSS you could probably override it

  10. Uljicni
    Member
    Posted 1 year ago #

    #second-menu a { font-size: 14px; color: #4b4b4b; text-decoration: none; text-shadow: 1px 1px 0 #fff; display: block; font-weight: lighter; }
    			#second-menu > ul > li > a { -moz-transition: all .3s; -webkit-transition: all .3s; -o-transition: all .3s; transition: all .3s; }
    			#second-menu > ul > li > a:hover { color: #fff; text-shadow: -1px -1px 0 rgba(0,0,0,0.1); -moz-box-shadow: inset 0 0 10px rgba(255,102,0,0.9); -webkit-box-shadow: inset 0 0 10px rgba(255,102,0,0.9); box-shadow: inset 0 0 10px rgba(255,102,0,0.9); }
    				#second-menu li.sfHover > a { color: #fff; text-shadow: none; }
    			#second-menu .main_text { color: #4b4b4b; }

    this is for menu, and i know alot about css i changed it all like i want it , it looks good on localhost and in dreamweaver, but when i put it on mine theme iit is ooverriden in inspector, eh

  11. Andrew
    Forum moderator
    Posted 1 year ago #

    Useful http://css-tricks.com/specifics-on-css-specificity/

    E.g.

    body #second-menu a
  12. Uljicni
    Member
    Posted 1 year ago #

    i will check it all out, consider this topic resolved and close it

Topic Closed

This topic has been closed to new replies.

About this Topic