Support » Installing WordPress » Theme loading but posts returning a 404 error

  • Aushiker

    (@aushiker)


    I am in the process of migrating over to a new host. I am going from Dreamhost to VentraIP.

    Currently my blog is working fine at Dreamhost (see http://aushiker.com) and I have the DNS servers still pointing to Dreamhost.

    However at VentraIP I am getting the theme up but no posts. The temporary URL for VentraIP is http://223.130.24.50/~aushiker/

    Also if I attempt to login to the admin section at http://223.130.24.50/~aushiker/wp-login.php it redirects me back to the Dreamhost admin error so I cannot actually make changes to WordPress at VentraIP other than via Cpanel.

    Intially at VentraIP the .htaccess file was blank so I copied over the .htaccess file frm Dreamhost but that is not making any difference. The .htaccess file as it currently stand is:

    [Code moderated as per the Forum Rules. Please use the pastebin]

    All the redirects are there because of old changes. Any thoughts?

    Thanks
    Andrew

Viewing 7 replies - 1 through 7 (of 7 total)
  • esmi

    (@esmi)

    Forum Moderator

    Try reviewing Moving_WordPress.

    Aushiker

    (@aushiker)

    Thanks for your suggestion but have worked through that document. I have spoken to VentraIP in the meantime and it seems that there temporary URL do not work with .htaccess files and that I have to edit the host file.

    Unfortunately that has made things worse. Now waiting on them to come back with ideas unless anyone has some advice.

    Regards
    Andrew

    esmi

    (@esmi)

    Forum Moderator

    You’ll have to wait until you change the name servers.

    Aushiker

    (@aushiker)

    Well the point is to test the installation before the change of the DNS servers hence the temporary URL.

    Andrew

    esmi

    (@esmi)

    Forum Moderator

    Then you have to discuss the .htaccess and temporary url issue with your hosts. There’s nothing in WordPress that can really help with this.

    Aushiker

    (@aushiker)

    I suspected that which is why I posted the following early on after a further investigation …

    I have spoken to VentraIP in the meantime and it seems that there temporary URL do not work with .htaccess files and that I have to edit the host file.

    Unfortunately that has made things worse. Now waiting on them to come back with ideas unless anyone has some advice.

    Thanks
    Andrew

    esmi

    (@esmi)

    Forum Moderator

    There’s nothing in WordPress that can help with this.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Theme loading but posts returning a 404 error’ is closed to new replies.