WordPress.org

Support

Support » Themes and Templates » Theme: Kubrick 1.5 – AllSidebar Edition

Theme: Kubrick 1.5 – AllSidebar Edition

  • Because it’s difficult enough having to explain it, I’ve gone ahead and modified the default (Kubrick 1.5) theme to provide a sidebar at all times:

    http://guff.szub.net/wp-content/default_allsidebar.zip

    To use, unzip to the directory/folder “default_allsidebar”, upload this to your wp-content/themes/ directory on your blog’s site, and select “WP Default – AllSidebar Edition” under Presentation in WordPress.

    Changes:

    * Templates previously single-column reset to the ‘narrowcolumn’ id.
    * <?php get_sidebar(); ?> added to those templates which lacked it.
    * Reference in header.php to kubrickbgwide.jpg removed.
    * A tiny bit of cleanup, clarification of comments.

    I also slipped in the get_calendar() template tag, though it is commented out; to display it, remove the html comments from around it in sidebar.php.

    Note: If this steps on any toes, so be it.

    UPDATE: For those who want to display links and login info in your sidebar at all times as well, I’ve separately made available a modified version of this:

    http://guff.szub.net/wp-content/kubrick_sidebar.zip

    Extract sidebar.php from the zip and replace your current one (either in default or default_allsidebar) with it.

Viewing 15 replies - 16 through 30 (of 76 total)
  • That can be done. In sidebar.php (in the theme’s directory), look for this section:

    <?php /* If this is the frontpage */ if ( is_home() || is_page() ) { ?>
    <?php get_links_list(); ?>

    Change it to:

    <?php get_links_list(); ?>
    <?php /* If this is the frontpage */ if ( is_home() || is_page() ) { ?>

    This will force only the ‘Meta’ section to appear on the home and Page pages. To show that everywhere, as well, remove this:

    <?php /* If this is the frontpage */ if ( is_home() || is_page() ) { ?>

    And below the Meta section, remove this as well:

    <?php } ?>

    Thank you!

    Awesome, Kaf!

    By the way, for anyone wanting the change jaijai asked for (and which I answered), you can also scroll up to the very first post in this thread, and click the link in the UPDATE.

    I know it can be missed; even I forgot about it. *<:p

    kafkaesqui:
    thankyou for your work.

    QUESTION 1
    do you have any clue?
    i have installed and selected
    and the header does not appear.

    how do i make it appear?

    QUESTION 2
    and which html tags do i remove from around calendar?
    i have removed the tags as below.
    is this correct?

    <!– WordPress Calendar is disabled per default. Remove the html comment tags if you want to use it.
    li id=”calendar”
    ?php get_calendar(2); ?

    –>

    Question 1: A link would help troubleshoot this.

    Question 2: You must remove the html comment tags, ie the <!-- and -->, so that only this remains:

    <li id="calendar">
    <?php get_calendar(2); ?>
    </li>

    I believe I’ve tripped across a problem related to the one you solved for jaijai. I’ve installed the allsidebar edition and it’s working great on my index, archives, category and single post pages. Where it seems to breakdown is on Pages (pages.php template). On a Page the sidebard shows up but the Pages list that shows on a post (single.php) shows only the header with no items in it.

    You can see an example at http://www.zims.com by clicking the Contact Us link on the main page.

    Any suggestions?

    Thanks,

    Mark

    Mark – for a moment there I only saw half a theme on your site (so I imagine you’re updating stuff). It also looks like you fixed your problem?

    Kafkaesqui,

    I was fiddling with the wp_get pages, trying to trick it into working with child_of, etc. Anyway no luck. Should be back to not working as described now.

    Thanks,

    Mark

    Just a note to say this has been solved, though I don’t quite know why.

    Here’s what I did. I created a new Page and did not specific a Page Slug for it just left it blank. Once this page was added the Pages list is now showing correctly.

    I had previously tried rebuilding my perma-link structure and nuked my .htaccess thinking that something was borked there. Creating this new Page (without the slug) seems to have unborked it.

    Sorry for the less than scientific explanation but I’m really not sure why this worked…

    Mark

    “As long as it works, who cares what the explanation is.”

    -Kaf Oseo, sometime in 1997 (or thereabouts)

    Hi. I’d love to see what this looks like, it’s hard for me to grasp it. Anyone care to post their blog so I can see it in action? Thanks.

    Easy to visualize: just imagine the home page layout of Kubrick on all pages. In any case, I’m currently running it on a test site:

    http://szub.net/ve&#97;

    “The download link does not work”

    The zip file is there.

Viewing 15 replies - 16 through 30 (of 76 total)
  • The topic ‘Theme: Kubrick 1.5 – AllSidebar Edition’ is closed to new replies.