Support » Fixing WordPress » theme keeps reverting to default

  • I’m currently having a few dramas with my site. Seems that every so often it decides to ignore my chosen theme (k2) and reverts to the default (kubrick) theme.

    To fix I’m having to check my site periodically to ensure that my selected theme remains in place and when it’s not, log back into the admin panel and re-activate my chosen theme.

    I’ve re-installed WP2.0.1, deleted, re-installed and deleted my custom theme, deleted and re-installed the K2 theme, deleted my tables and re-installed from backup. Only themes currently installed are the two defaults + K2, active plugins are restricted to Akismet, Related Posts, Markdown, Dunstans Time Since, Extended Live Archives. I’m frankly not sure what else I can do.

    Any help is diagnosing and fixing this issue would be much appreciated.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The real “drama” is that we do not support K2 here. K2 is not only a theme, it’s a modification of WP – you could read this on the main page of the thing you are using. The official support site for this modification is here:

    Well technically, there’s little that K2 does which all themes aren’t capable of since 2.0, what with functions.php and all…

    That said, I do welcome all K2 support in the K2 support forums, so as to make it easier for people to find help.

    PS: The forums have been moved to

    As posted in detail here, I’ve now determined that it’s unlikely that K2 is the cuplrit here.

    I’m currently running the ‘Almost Spring’ theme and my problem persists. Prior to installing ‘Almost Spring’ I was running ‘K2’ (as described above) with the same issue experienced. K2 has now been removed from my themes directory and any related entries removed from the ‘wp_options’ table of my database.

    To reiterate, I can activate my chosen theme, everything runs as expected for several hours then, for a reason that I can’t determine, my site reverts to using the WP default theme. No ‘broken theme’ error is reported from the Dashboard and the theme-related ‘wp_options’ entries ‘theme’ and ‘stylesheet’ are updated to the value ‘default’.

    In an update to my initial post here, I’m running WP 2.0.1 with only the Akismet and Markdown plugins activated.

    Anyone got any ideas?

    I’ve personally never run across wp doing this sort of thing in over a year of using it.

    Have you checked with your host just to make sure first that there’s nothing odd going on with the server?

    Failing that, have you tried seeing what happens if you disable ALL of the (two) plugins?

    I’ll log a support ticket with my host to cover this base, though I’m running another WP blog in the same database (different tables ofcourse) which isn’t experiencing any such issues. I’m therefore not convinced this will provide any additional info.

    I can’t disable Markdown currently as I’m using it fairly extensively to format my posts. Save for editing each post, disabling is not feasible.

    I’ve already tried disabling Akismet with no success, the issue remained.

    Does the other blog run Markdown?

    Yes. Confirmed installed and active.


    Okay, if this was me, I’d set up a second database for just the problem install, dump the current database, install a second instance of wp using the new database, and import the dump.

    That would give you a benchmark….

    I’ve done that in the existing database… twice. Exported my tables via phpmyadmin, dropped the old ones and have imported the export with IF EXIST DROP + ADD TABLES queries intact.

    Have also reinstalled WP 2.0.1 twice from vanilla/freshly downloaded zips.

    I’ll try the same again with you new database idea later today.. I’m willing to try anything at this stage!

    Thanks for your help, I’ll let you know how I go once I’ve restored everything.

    Yes, please do. I’m here off and on all day most days, though tomorrow is 80-mile-round-trip-to-town-so-hit-every-store day, so it will be late. But podz (who’s the best there ever was at this sort of thing) will be here during the day tomorrow….

    Oh…. one other thing you could try with a vanilla db: install 1.5.2 from and then UPGRADE….

    I know that sounds weird. But believe me when I tell you that my upgrade installs of 2.0+ over 1.5.2 act TOTALLY differently from my vanilla installs.

    Will do, thanks for all your help.

    Best of luck…. I will check on this topic when I get home tomorrow.

    I’ve now moved my WP install to a fresh database, installed 1.5.2, upgraded to 2.0.1, imported old backup tables and re-installed my custom theme.

    touch wood, all has been running as expected for the past 12 hours 🙂

    Keep us posted, this is really interesting. Crossing fingers here!

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘theme keeps reverting to default’ is closed to new replies.