Support » Plugin: Block, Suspend, Report for BuddyPress » theme issues implementing this plugin

  • Resolved beachcalsix

    (@beachcalsix)


    Hi!
    First off, I’d like to say, I really love this plugin and hope there is a way to keep it. Otherwise, I’d have to implement some kind of form system which is a time consumer.

    Such a great plugin! If I can make it work it would be so amazing!

    Ok, the issue(s)

    I’ve scoured the forum here trying to find similar issues. I did, and after reading different posts I think the problem has to do with my theme, not you’re (which I do have installed)

    My theme is Olympus.

    Here are some screenshots showing my problems

    So as you can see from the screenshots, the block button is off-center, for some reason, on the members’ directory page.

    The second issue is the report button is nowhere to be seen on the actual user profile pages. The only thing I can find is the block button.

    To be honest, I love this plugin so much I’d probably keep it even with the bugs! These are minor issues and I can (kind of) work with them but it would be wonderful if there was a way to fix them that I’m not aware of!

    Any input or help would be very appreciated!

    Thanks for your time!

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Ben at Bouncingsprout Studio

    (@bouncingsprout)

    Hey @beachcalsix,

    Firstly, thank you so much for your awesome compliments about Block, Suspend, Report for BuddyPress. We have had some great feedback from site owners who have had their administration time halved (or even more) because they no longer need to ‘police’ the users on their sites.

    Unfortunately, you are correct. Actually, it’s not Olympus that is the problem, but their inclusion of a 3rd-party tool called ‘Youzer’.

    I will write a blog post on this in the coming weeks, but to summarise for you, Youzer is a wrapper that sits over the top of BuddyPress. It makes sweeping changes to the look and feel of the BuddyPress ecosystem.

    This means that to use other 3rd-party plugins, you will need to do some tweaking to get the plugins to play nicely with Youzer. Youzer ‘overrides’ native BuddyPress functionality, so there is little we as developers can do.

    I have written a bit of css that solves the button issue. Please add it via appearance->customise->additional css

    .youzer #yz-members-directory .bptk-block-list a{-webkit-box-pack:center;-ms-flex-pack:center;justify-content:center}.youzer #yz-members-directory .bptk-block-list a:before{content:'\e90B';font-size:20px;font-family:olympus!important;font-weight:500;margin-right:8px}

    I have added an icon, but really it is for the theme developers to find an appropriate one from their own font library, as if there were 48 hours in a day, I still wouldn’t be able to provide icons for the 1000’s of themes out there!

    On the report button issue, please confirm that you have enabled member reporting vis BSR -> Report -> the ‘General’ tab.

    If you have, then we will need to do some more digging as I have Olympus installed and see this:

    https://prnt.sc/tnqp54

    Hope that helps – if it does, please let me know, and if you have a few minutes I’d be really grateful if you could leave a review.

    Thank you!

    Ben

    Thread Starter beachcalsix

    (@beachcalsix)

    .Thanks for your help!

    Yes, I didn’t have reporting on…whoops. I thought I had turned everything on.

    I did put that code in and no change?

    Did I put it in the right place? Here is a screenshot:

    Thanks again! I’ll definitely leave a review.

    Plugin Author Ben at Bouncingsprout Studio

    (@bouncingsprout)

    Hey @beachcalsix,

    Good news on the report button. I am going to create a better ‘getting started’ page for the docs, as you are not the first!

    You should be able to add that code in any ‘additional CSS’ function, either in the theme or a separate plugin. I added it directly into the theme as above, and it now looks like this:

    https://prnt.sc/toodf6

    If you send me a link to a register page for your site (via the contact form on my site is fine, if the site is sensitive, or not for public release), I can see what might be blocking it. Please DO NOT send any admin credentials.

    Ben

    • This reply was modified 7 months ago by Ben at Bouncingsprout Studio. Reason: Why can I never spell 'separate' correctly? EVERY single time
    Thread Starter beachcalsix

    (@beachcalsix)

    Tried refreshing and entering the code again and still no luck. I sent you the register page on your contact form.
    Hope it’s correct. The site is still under maintenance though. It should work though!

    Thanks again!

    Plugin Author Ben at Bouncingsprout Studio

    (@bouncingsprout)

    Hi @beachcalsix,

    I’ve successfully registered, but you have no members that I can see (https://your-website/members). You also don’t have any menus ready yet, so I can’t tell if the members directory is a different page.

    I will need you to add some dummy members so we can see what’s going on, or change your settings to make other members visible.

    Ben

    Thread Starter beachcalsix

    (@beachcalsix)

    I do have about 10 dummy members on my end. Are none showing up there?
    I was having some issues with the menus breaking on mobile so I’ve been chatting with theme support to fix that and they told me to disable them. I can turn them back on if you need
    The members’ page is /members-2

    Plugin Author Ben at Bouncingsprout Studio

    (@bouncingsprout)

    Hey,

    The members page says ‘access restricted’, and tells me I need to sign up to a challenge?

    Ben

    Thread Starter beachcalsix

    (@beachcalsix)

    Oh sorry, I told you it’s in maintenance. I thought the sign up form would work but it’s still linking incorrectly. Let me fix it.

    Plugin Author Ben at Bouncingsprout Studio

    (@bouncingsprout)

    Don’t worry! I’m in. You have a free supporter membership.

    Okay – good news, it all seems to be working now – I’ll email you the link to what I see.

    You do have some styling issues, but they are being caused by whatever plugin you are using to add badges – this relates to the issue with Youzer I mentioned in my first reply.

    Ben

    Thread Starter beachcalsix

    (@beachcalsix)

    Ok, the quickest fix I could do is just to have an automatic popup with the sign up form. One of my plugins sends non logged in members to that page. I’m still working on that and linking within the menus. Sorry about that!
    The pop up should work and the members’ page should show up now.

    Thread Starter beachcalsix

    (@beachcalsix)

    Or would it be easier just to make a dummy account for you to log in with?

    Thread Starter beachcalsix

    (@beachcalsix)

    Wow, how did you do that? Literally 30 minutes ago they were off-center!

    Thanks so much for taking the time out of your day to help me!

    Yes, you’re has given me a lot of headaches with the site.

    Thanks again!! You’re a lifesaver!

    Plugin Author Ben at Bouncingsprout Studio

    (@bouncingsprout)

    Absolutely no problem at all.

    Enjoy the rest of the week,

    Ben

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘theme issues implementing this plugin’ is closed to new replies.