WordPress.org

Support

Support » How-To and Troubleshooting » Theme installed but incomplete

Theme installed but incomplete

  • I am trying to use a new theme and uploaded the entire directory into the themes folder but when I go to Presentation it says:
    The following themes are installed but incomplete. Themes must have a stylesheet and a template.

    The new theme does have a stylesheet and template. styles.css and index.php

    Anybody have an idea what’s wrong?

Viewing 14 replies - 1 through 14 (of 14 total)
  • Which theme is it ?

    dark_maple

    Hmm..I just uploaded that and WP is reporting no errors.
    It is all in a folder but not a folder in another folder ?

    Yes. I just uploaded a different theme in exactly the same format and it works perfectly.

    Must be a minor user error as podz suggests. Dark Maple is normally fine.

    On the server, if you open the dark_maple, you see the css and files ? or do you see another folder ?

    I see the styles.css and all the other files. No additional folders in there.

    There should be at least one folder in it: the images folder.
    I assume something went wrong during the download/upload, because this is the first time somebody reports the theme being “incomplete”.
    If you have further difficulties don’t hesitate to conatct me (my name here @ my domain)

    My mistake. There is an images folder in there that has 2 images in it.

    Hi Moshu,

    I downloaded the theme from your site, uploaded it and it fixed the problem.

    Thanks,
    Frances

    I found that the unzip program I used seemed to affect the “template is missing” problem. I extracted with just the windows program and got that error. But uploading the Dark Maple theme that was extracted with winzip worked.

    I just dl’d and installed Dark Maple tonight. I had the same problem with the version I dl’d from WordPress, but the version from Moshu’s site is working. So I think that something is wrong with the version on wordpress.org .

    I’m trying to install 2.0.4 for someone – I already have 2.0 and 2.0.2 on 4 of my own sites and never had any problems, but now I tried 2.0.4 4 times, 2.0.3, 2.0.2 and even 2.0 – and every time I get:

    “The following themes are installed but incomplete. Themes must have a stylesheet and a template.”

    I tried unzipping with 3 different software, I tried 2 different FTP applications, I uploaded everything in binary mode and I even tried installing WP 2.0.4 from Fantastico admin panel. And I get the same message in the Themes section. All the paths are fine and style.css files are properly located. By default only “default” theme appears in the list of incomplete themes.. I can’t access “Theme Editor” pages – gives me: “The requested theme does not exist.” message. If I upload another theme – Classic theme appears as second one in the incomplete themes list.
    And by the way – the host is the same I have 4 other WP running on. Have no idea what it is. Never had any problems with WP before.

    Any ideas at all?

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Theme installed but incomplete’ is closed to new replies.
Skip to toolbar