WordPress.org

Forums

[resolved] Theme installation from search not working (11 posts)

  1. Rudy64
    Member
    Posted 3 years ago #

    In the admin dashboard, I go to Appearance/Themes/Add New, and search for themes. I get the list of themes with "Install" and Preview" as options. If I click either one of those, the screen darkens, but nothing else happens (the theme install or preview windows do not appear in the overlay, in other words...the background only darkens in preparation for it).

    Browser is Google Chrome. OS Win7-64 bit.

    Let me know if you need more info to troubleshoot and I will post it here. Thanks!

  2. Rudy64
    Member
    Posted 3 years ago #

    BTW, the plugin installer works fine--I search for and installed a plugin with no problems whatsoever. I can only reproduce the problem in the Themes installer.

  3. I tested on Chrome on XP and Lion, and it works fine on both. Have you tried turning off ll your plugins?

  4. Rudy64
    Member
    Posted 3 years ago #

    All plugins off, still not loading. The 3.2.1 version on the same server is functioning properly, even with AdBlock and Notscript enabled.

  5. Did you test turning off adBlock and NotScript for 3.3?

    Have you tested on a different browser?

  6. Rudy64
    Member
    Posted 3 years ago #

    Yep, as mentioned, the plugins are all disabled, and it still happens with 3.3B1. But with a full load of plugins, I don't have this problem on 3.2.1.

    I'd have to fire up another computer to see if it's browser-dependent. Let me give that a try later on today, as I'm working on something with a deadline right now. I have access to all the major browsers on the other computer.

    BTW, what powers the overlays? Is it JQuery or something similar?

  7. jason_lane
    Member
    Posted 3 years ago #

    Works for me in Chrome on OSX, but your description sounds like a Javascript issue. Try taking a look at Chrome's Javascript Console to see if there are any errors there when you click on the links.

  8. Sorry, when you said 'All plugins' I presumed you meant all WordPress plugins (and I have no idea if AdBlock and Notscript are WP or Chrome plugins so I decided to make sure).

  9. Rudy64
    Member
    Posted 3 years ago #

    Definitely a Javascript issue, and my apologies on top of it. The developer console helped me find the problem.

    I overlooked having the "Send from Gmail (by Google)" extension still enabled. As I looked at the developer console, I noticed it was loading (as it normally does) but it threw no errors. That clued me in, though, that I still had it enabled. Way down in the list. (And these aging eyes aren't what they used to be!)

    So, there is some incompatibility there. This extension rewrites URLs on the page so I can reply in a Gmail app rather than have mailto: links fire up Outlook. Not sure if it is worth having WordPress debug it or not, but if the issue comes up again, at least we know one of the causes. There was apparently some change in JS between 3.2.1 and 3.3B1 that causes this incompatibility.

  10. Rudy64
    Member
    Posted 3 years ago #

    @Ipstenu Oh jeez...I thought you meant my browser plugins. ;o) No harm done though! This was a new WP install I was working with, so I had only installed the one plugin to see if the overlay was working properly. Otherwise, no, is a fresh installation.

    So no, I hadn't yet totally messed up the 3.3B1 WP install by throwing my usual barrage of plugins in place.

    BTW, is there a way (perhaps via wp-config.php) to disable all plugins with one line?

  11. Rename the plugins folder ;)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.