WordPress.org

Forums

[resolved] theme index.php not moving to subdirectory- Yahoo host (8 posts)

  1. tyronerock
    Member
    Posted 9 years ago #

    I am new to WordPress and php and have been working on this for a day and a half. When I install wordpress 2.0 the default theme works perfectly. There is already a working index.php file in the root directory along with the blog folder(I choose to make my blog my homepage during install). when I upload the devenir_en_gris theme files. The index.php file is still there but now it is blank. Also when I try to move the the files into the wp/content-themes subdirectory it will not allow me to move the index.php file through the subdirectories because it already exists.
    The theme shows up in my Presentation - Themes option page, but when I activate it not only will it not work but the default theme wont work either. Can anybody please tell me what I am doing wrong? Any help would be gratly appreciated.

    Thanks in advance

  2. moshu
    Member
    Posted 9 years ago #

    There is already a working index.php file in the root directory along with the blog folder(I choose to make my blog my homepage during install).

    There is some contradiction here...
    WP is either in the root or in a folder. Which one is true?
    And what is the "working" index.php file?

    and this:
    it will not allow me to move the index.php file through the subdirectories
    simply doesn't make sense for me - but I might be tired :)

  3. tyronerock
    Member
    Posted 9 years ago #

    Sorry Moshu. Maybe I'm not explaining it proplerly. Yahoo hosting has a wordpress auto-install feature. When I install wordpress, there are only two things on the root directory

    1)The folderwith all the wordpress files in it, which is called "blog", and
    2)The index.php file.

    When I click on the index.php file to view it, I can see the homepage of the default theme that comes with wp. I have been uploading the files for the devenir en gris theme which also has an index.php file. The files get uploaded to the root directory by defaultand then I am supposed to move them to whatever subdirectory I am going to keep them in(I am using the "easy" upload tool that comes with Yahoo hosting). Now the index.php file no longer shows the homepage when I click on it, instead it is blank. When I try to move the theme files into the "blog" folder all of them move successfully except for index.php and I am told that i cant move this file because there is already a file in the folder I am trying to move it to called index.php.
    At this point there is nothing at all showing on my site, not even the original theme.

    I hope I've explained it a little better this time. Thanks for the help

  4. moshu
    Member
    Posted 9 years ago #

    I have been uploading the files for the devenir en gris theme which also has an index.php file. The files get uploaded to the root directory by default
    Every theme MUST have an index.php file!
    If you use a FTP client you are in control where the files get uploaded. Every theme should be uploaded in its own directory under wp-content/themes/. So it should be:
    wp-content/themes/devenir-en-gris/ or something like that.
    In the root directory there should be the WP index ("short and sweet") and every theme folder has to have its on index. Upload the themes in their own directory.

    Always beware of any "automatic" tool - they do what they wnat, not what you want :)
    Use a FTP client (e.g. FileZilla) and not the "easy" stuff - you can see it makes your life miserable.

  5. tyronerock
    Member
    Posted 9 years ago #

    Much appreciated moshu..I will try that. I'll let u know how it goes.

  6. tyronerock
    Member
    Posted 9 years ago #

    Moshu, thanks alot, you were right. FileZilla works perfectly. i was able to upload the theme files right into the wp-content/themes folder and the theme is working.
    The only thing is that i need to make the blog my homepage now because I didn't select his option when I was installing it. What is the easiest way to do this now that the index.php file is in the themes folder?

  7. brittanie
    Member
    Posted 9 years ago #

    I suggest you uninstall Yahoo's installation (which you can do from the control panel) in then re-install all the wp files using your FTP client onto the root. When you download wordpress, it comes in a file called "WordPress." Open this file and install everything inside it to your server five FileZilla. One of the issues I have with Yahoo's installation is that they require you to put your blog in a subdirectory, but you don't really have to. The new install will make your blog your home page.

    If you have already posted a few entries to your blog, you can export them from the database and re-import them into the new install. Do a search for "moving wordpress" to learn how to do this.

    Good luck!

  8. tyronerock
    Member
    Posted 9 years ago #

    Got it working. I have all the files I need in the root directory and my blog is my home page with the new theme working perfectly. Moshu and Brittanie, thanks alot!! I hope you guys are around the next time I need help.(Which i'm guessing will be soon)

    Peace

Topic Closed

This topic has been closed to new replies.

About this Topic